A service I have written that uses BITS (Background Intelligent Transfer Service) to auto update itself is having a problem on some machines (Windows 7 so far).

I have been investigating and have discovered that some of the jobs that my service adds to the bits queue are failing immediately with the error code 0x80072efd (a connection with this server could not be established). The is not problem with connecting to the server for the download as it works fine on the same machine using IE (or any other web browser) and other clients can connect and update from the same server.

I tried using the BITSADMIN.exe tool to add the jobs manually and they worked ok. I then changed the account my service was running under to the network service account so the bits jobs would be created with a different owner and the jobs completed successfully.

My question is I don't want to run my service as this account as it wont have the required local permissions, so how to I change the permissions of the local system user to allow it to download from the HTTP source, I'm not aware of any way of this being restricted for this account but it obviously is.

1 Answer 1


I have found out what the issue was,

my mistake was thinking that BITS used the same proxy settings defined in IE but it has its own settings for the service accounts that can only be changed using the BITSAdmin tool.

When I initially ran this it showed some invalid proxy settings

C:\Windows\System32>bitsadmin /util /getieproxy localsystem

so I then ran this to clear the proxy settings.

C:\Windows\System32>bitsadmin /util /setieproxy localsystem NO_PROXY

BITSADMIN version 3.0 [ 7.5.7601 ]
BITS administration utility.
(C) Copyright 2000-2006 Microsoft Corp.

BITSAdmin is deprecated and is not guaranteed to be available in future versions of Windows.
Administrative tools for the BITS service are now provided by BITS PowerShell cmdlets.

Internet proxy settings for account localsystem set to NO_PROXY.
(connection = default)


Finally I restarted BITS and the jobs started to download and completed with no issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.