following test setup is given:

server1 - 1 network card connected to internal network ( + gateway

server2 - 2 network cards (1. connected to internal network ( / 2. connected to the internet with static ip address + default gateway is set)

Both servers can ping each other, server2 can ping addresses in the internet.

I installed the "Remote Access" role on server2 with the "Routing" option. Enabled NAT in the RRAS Manager and selected network card 2 as internet access card.

-> server1 can now ping addresses in the internet via NAT on server2.

But as soon as i run the DirectAccess configuration manager an enable DirectAccess+VPN on server2 NAT stops working. The configuration in the RRAS Manager still exists.

Any idea why?

The goal is to have an internal network where each server can access the internet via NAT and one server acts as VPN/DirectAccess server+NAT Router.

  • Just want to confirm the problem. I have a Microsoft Server 2012 installation. I have set the network up according to the Microsoft Test Lab for DirectAccess. The only difference is that I construct and test a NAT on my EDGE computer before configuring DirectAccess. After installing DirectAccess, none of the computers on the CORPNET ( network can access the Internet. Further, if I go back and install a NAT manually, it won't work though it shows the mappings. Further, if I de-configure DirectAccess, the NAT starts working again. – Quarkly Oct 31 '12 at 16:26
  • Additionally, the DirectAccess Test Lab Guide directs us to use (the Edge Computer) as a default gateway, even though DirectAccess doesn't appear to be providing this function. What gives? – Quarkly Oct 31 '12 at 16:28
  • Same problem was reported here without any solution: social.technet.microsoft.com/Forums/windowsserver/en-US/… – dna Sep 17 '13 at 22:07

Just had this same issue on a 2012 server for a client. Originally had NAT setup, and then later setup VPN. VPN worked, but NAT stopped working. Fixed it by disabling/removing remote access from the "remote access management console" and then going back to "routing and remote access" via the server manager > tools screen, and re-setting up from there via the wizard. (I selected VPN and NAT as the features I wanted to enable.) When done together like this, it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.