1

we have recently (foolishly) installed the updates on some of our servers, which have a bit of hardware attached via USB that presents itself as a serial (COM) port.

The strange behaviour is that if I start a cmd shell on the server via VNC, I can open the serial port. If I run a service and start it from there (telnet, jenkins) then I receive a "not found" error for it.

IE:

C:\Documents and Settings\some_user>echo 1 >COM4:
C:\Documents and Settings\some_user>

on the local cmd will work, and on the remote telnet will give:

C:\Documents and Settings\some_user>echo 1 >COM4:
The system cannot find the file specified.
C:\Documents and Settings\some_user>

I cannot see any security settings on the Device manager settings panel for this device.

3
  • I am currently reviewing the updates installed to see if any specify changes to serial or device policies. Oct 26 '12 at 10:50
  • And none of them seem related or have any known issues relating to it. Oct 26 '12 at 10:57
  • I've tried setting "GPE\Computer Configuration\Administrative Templates\Windows Components\Client/Server data redirection\Do not allow COM port redirection" to disable (from not set) - actually - maybe I need to enable this - I don't want redirection. I think I am going to try removing all the recent updates and reboot one of the affected servers. Oct 26 '12 at 11:08
1

Backing out the update KB2724197 will fix this. I need to investigate why - this one makes the serial port accessible remotely again.

4
  • I now need to find out how to prevent this being installed again - however, later and different updates may rebreak what ever thing was broken with this. Oct 26 '12 at 12:54
  • Found here - superuser.com/questions/171794/… - in 2003, go to windows update, click custom (when ready), untick the update, and tick "don't show this update again". Click review and install to apply the change. Oct 26 '12 at 12:57
  • Okay - plan to investigate what changed (hatched by a cunning colleague) - verify it works, dump the registry, install the update & restart, verify it's broke, dump the reg again, diff the two and look for likely suspect configuration changes. Oct 26 '12 at 13:14
  • Add - upon installing it, the verifying it is broke step failed - the update having been backed out, and reinstalled is not reproducing the problem. Oct 26 '12 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.