I have previously regularly created closed networks of Windows XP machines, that is, several machines networked together with switches and routers (& static IPs) but no connection to the outside world (no DNS for eg).

It would seem that Windows 7 is designed purely for the internet-connected computer. When setting up a network similar to above I am plagued by "no internet access" and "unidentified network" messages and have to sift through the public, homegroup, work settings etc.

My PCs regularly swap between the network name i've applied and "unidentified network" and i often wish I could have my Win XP days back!

What I want to know is: is there a way to operate a Win7 PC in a closed network as you would have done with XP - no "unidentified network" messages etc. (it would appear this is due to lack of DNS, but there's nothing I can find in the sharing centre/troubleshooting that says this officially)

(i am aware of methods to disable "no internet access" and "default to work location" in secpol.msc)

  • So, just to be clear, your only problem is the little icon that says you have no Internet connectivity? – MDMarra Oct 26 '12 at 11:58
  • Hi MDMarra, the main issue is the "unidentified network" messages. I've read plenty about them, but I suspect it's down to my network not having DNS (just a few Cisco routers, no internet connection). – Ian Oct 26 '12 at 12:19

The easiest way to 'fix' this behavior is to convince Windows that it has internet access. This turns out to be quite easy.

  1. Run a tiny web server internally that is spoofed with the dns name www.msftncsi.com.
  2. Configure it to serve up ncsi.txt at the root, the contents of which may or may not matter, but Microsoft's file just says "Microsoft NCSI".
  3. There is no step 3.
  • Smithian, thanks for this. I am assuing that will fix the "no internet access" issue, but do you know what Windows does in order to ascertain "unidentified network"? Have read plenty on this, but everyone's problems seem to be different. For me, I have the name of my network showing, then if I hibernate a PC and wake it up, or unplug & replug the network lead it changes to "unidentified network", sometimes with "!" sign between PC and network, sometimes without – Ian Oct 26 '12 at 12:23
  • 1
    I believe that this is related to the DNS lookup of www.msftncsi.com. Googling ncsi should help out with some more specifics. – smithian Oct 26 '12 at 12:25

Looks like this page tells you how to keep a computer from checking for internet connectivity.

Look at the section titled To Prevent NCSI from Communicating Across the Internet by Changing a Registry Setting (pasted below).

To Prevent NCSI from Communicating Across the Internet by Changing a Registry Setting

  1. For best results, close all programs on the computer on which you are changing the registry setting.

  2. To open a command prompt as an administrator, click Start, point to All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.

  3. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.

  4. Type: regedit

    • Caution: Incorrectly editing the registry may severely damage your system. Before making changes to the registry, you should back up any valued data on the computer. You can also use the Last Known Good Configuration startup option if you encounter problems after manual changes have been applied.
  5. Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet

  6. Under the Internet key, double-click EnableActiveProbing, and then in Value data, type: 0

    • The default for this value is 1. Setting the value to 0 prevents NCSI from connecting to a site on the Internet during checks for connectivity.
  7. Click OK.

  8. Restart the computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.