I have an issue with my internet connection. I am using VPN (Aventail Client) to access the local resources. When connected to VPN the Internet traffic passes through it, not through my LAN or Wi-Fi network. I would like to change the routing table to use the Wi-Fi adapter of the PC for WAN traffic. I have routing file, which works very well and routes the traffic in this way, but only when I am physically connected to the local network through LAN. But I can't set it to work with the VPN connection, because I have no gateway when I am connected to it. Etc this in bold is missing. What to do?

route change mask metric 200 if 12
route change mask metric 400 if 11
route add mask metric 100 if 11
route add mask metric 100 if 11

2 Answers 2


I'm not 100% on SonicWall / Aventail but usually how your WAN traffic is controlled by a policy from the firewall provider (the place your connecting) or an option in the actual client itself.


The adapter order will usually take precedence over the metric on the routes, so you're better off removing the default route thru the VPN, so you just have your normal default route and your two remote network routes.

I am not familiar with that particular VPN client, but some adapters will do some trickery to make it so you can't mess with things like this, so if you're still scratching your head it may just not be possible to attack it this way.

Also, as someone else mentioned, usually this is controlled either in the VPN client itself or on the security appliance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.