in the Console , SQL Server Configuration Manager

I get error 10048 when start sql service

and this in event history:

The SQL server service terminated with server-specific error. Only one usage of each socket (protcol/network address/port) is normall permitted. Any idea howto fix this ? Port set is the default 1433... If this is turned off, which is default of course, SQL service starts like a champ. I have done this config many times on other servers with no problem.

  • 3
    Do you have other instances of SQL installed on this server? Is there another process using port 1433? Run netstat -a -n -o from a command prompt and look for port 1433. If you find it then match up the PID listed with Task Manager and see what process is using port 1433. – joeqwerty Oct 26 '12 at 21:33

Sounds like there's something else already running on TCP port 1433. Stop the SQL Server. Then from a command prompt run

netstat -a -b

This will show you all the TCP ports which are in use and the name of the application which is using it. Find the application which is using TCP port 1433 and change that application to use a different port number.


Figured it out. Right clicking the TCP/IP option there is an option to set 'Listeners' to all. Which is default, I changed this 'no', and it started so something must be up with my interfaces...

  • Holy crap man... this worked... I was going crazy... SQL Server 2017 installation was failing with "Wait on the Database Engine Recovery Handle Failed SQL Server"... this fixed it for me. THANKS! – Leniel Maccaferri Aug 29 '18 at 15:45

I found this problem when trying to start my MSSQL Service.

At first, I changed listeners all from yes to no (as suggested in the accepted answer by @ebel). However, this way I was not able to connect to the server.

As @mrdenny suggests I identified the application using that port. In my case it was another instance of MSSQL Server running in a docker container.

Take also a look at this post for identifying the error logs of MSSQL Server and other applications running in that pot: https://blog.sqlauthority.com/2017/01/07/sql-server-unable-start-sql-service-server-tcp-provider-failed-listen-1433-tcp-port-already-use/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.