I have just installed VMWare ESXi and imported one physical machine without issue and one virtual machine, from an older version of VMWare Server on a Linux system, to it without issue. But I have another machine (Windows XP), virtual running on the VMWare Server, that I can't get the Converter to work with.

Converter runs, says everything is fine, but when I go to the ESXi VSphere manager and hit the button to power up that vm, the console stays black with a blinking cursor and the processor for that VM spikes 100% and stays there. An event log item in VSphere warns something about activation issues with Windows.

Has anyone else run into this issue before? Is it something with the disk controller? I copied the folder with the VM directly to the storage drive on ESXi hoping to create a new machine and point the data store to that folder or at least that drive image; nope, something about not using an IDE controller (must be something with the older format).

In short, converter is doing something that particular machine doesn't like, and I can't find a way to simply open that hard disk image or convert it unless someone else has seen this. I try attaching a bootable CD image for disk repair to see if it can check the hard drive but I can't seem to get the console to boot from it...either too slow on the button or it just isn't able to easily boot from a virtual drive image (.iso).

Any suggestions or help?

  • It's safe to ignore the error about activation issues - it's just warning you that if you change the configuration too much after its been activated you might need to re-activate. – Mark Henderson Jul 22 '09 at 22:06

Okay...updated, and it seems to be working!

First, had to delve into the settings a bit. I uploaded a RIP (rescue is possible) CD to the datastore along with one of our XP install disks.

Second, the bootup was impossibly fast. There's a setting to control that, and to control forcing it to go to the BIOS setup at boot, from the edit settings for the VM. Need that to change boot order to work with the CD before the hard disk.

Third, attach CD ROM image from datastore (RIP CD) to the CD drive.

Fourth, remember to "connect at startup" for the CD drive. Whoopsie.

That's how to get it to boot from another source. I booted RIP and had it run Testdisk, which did some repairs to the partition but it kept detecting that the number of heads was misset (I'd change it in the geometry menu but it just wasn't "saving" the new settings...haven't figured that one out.) Reboot, this time it got to the point where it would blue screen. Progress!

Next was a trip to Windows XP's bootable ISO and from there into the recovery console. I ran fixmbr, then fixboot, then chkdsk c: /p twice. Did a quick dir to see if files looked intact (like ntdetect and ntldr) and then exited, shut down the VM and removed the disc from the virtual drive (disconnect at powerup) and crossed fingers.

The VM booted up. YAY!

Thank you to all who offered suggestions!


I have spoken with them before about the best way to move between infrastructures like you are describing. They always recommend the P2V converter, is the converter giving you any errors when it runs? You didn't mention any in your post but it seems odd that it isn't. I have had servers want to activate after a P2V before but that never caused the behavior you mention. Have you considered making an image of the machine, then loading that image onto a "blank" VM on your ESX server using Ghost or Acronis?

  • The converter is not giving an error; it transfers the image to the ESXi server and finished the task "successfully". I actually thought of making an image with Partimage about 10 minutes after I sent the message; haven't tried it yet though. I need to find a way to get it to boot an iso image in order to do that; right now trying to intercept the boot isn't working (I see the BIOS message flash up and disappear on the system "locking up" almost immediately)... – Bart Silverstrim Jul 23 '09 at 1:51

before you run the vcenter converter tool, select the disc to 'SCSI' instead of 'IDE'...it works for me...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.