I run a FreeBSD 9.0 server with ZFS pool version 28 and ZFS version 5.
I had two pools with a log on ssd's two partitions. These pools was created on FreeBSD 8.2 with ZFS pool version 15, and ZFS version 4.
After I upgraded to the new zfs version, I tried to remove the SSD log device from both pools both command was successful (no error message). One of the pools was the log removed, but the other still there, I down the server removed the ssd physically, and hoped it will be forgot by the zpool.
The zpool became degraded as ssd was missing. I tied to remove again. No error message, but the log device entry still there. After it, to became the pool online again, I created a file on the root UFS partition and replaced the missing to device to this file. It was successful, the pool again online. However I can't remove the log device from the pool.

Where can I have to look for error messages? (in dmesg there is nothing about it, also the zfs remove doesn't have any error message, it's seem like it was successful.

  • How was the log device added? Or was it attached? Was one of the two log devices mirrored? If there was a difference between the pools and how the log device was included, this could lead to the way you have to remove/detach it again. – Jimmy Koerting Dec 20 '13 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.