So the release of Windows Server 2012 has removed a lot of the old Remote Desktop related configuration utilities. In particular, there is no more Remote Desktop Session Host Configuration utility that gave you access to the RDP-Tcp properties dialog that let you configure a custom certificate for the RDSH to use. In its place is a nice new consolidated GUI that is part of the overall "edit deployment properties" workflow in the new Server Manager. The catch is that you only get access to that workflow if you have the Remote Desktop Services role installed (as far as I can tell).

This seems like a bit of an oversight on Microsoft's part. How can we configure a custom SSL certificate for RDP on Windows Server 2012 when it's running in the default Remote Administration mode without needlessly installing the Remote Desktop Services role?


3 Answers 3


It turns out that much of the configuration data for RDSH is stored in the Win32_TSGeneralSetting class in WMI in the root\cimv2\TerminalServices namespace. The configured certificate for a given connection is referenced by the Thumbprint value of that certificate on a property called SSLCertificateSHA1Hash.

UPDATE: Here's a generalized Powershell solution that grabs and sets the thumbprint of the first SSL cert in the computer's personal store. If your system has multiple certs, you should add a -Filter option to the gci command to make sure you reference the correct cert. I've left my original answer intact below this for reference.

# get a reference to the config instance
$tsgs = gwmi -class "Win32_TSGeneralSetting" -Namespace root\cimv2\terminalservices -Filter "TerminalName='RDP-tcp'"

# grab the thumbprint of the first SSL cert in the computer store
$thumb = (gci -path cert:/LocalMachine/My | select -first 1).Thumbprint

# set the new thumbprint value
swmi -path $tsgs.__path -argument @{SSLCertificateSHA1Hash="$thumb"}

In order to get the thumbprint value

  1. Open the properties dialog for your certificate and select the Details tab
  2. Scroll down to the Thumbprint field and copy the space delimited hex string into something like Notepad
  3. Remove all the spaces from the string. You'll also want to watch out for and remove a non-ascii character that sometimes gets copied just before the first character in the string. It's not visible in Notepad.
  4. This is the value you need to set in WMI. It should look something like this: 1ea1fd5b25b8c327be2c4e4852263efdb4d16af4.

Now that you have the thumbprint value, here's a one-liner you can use to set the value using wmic:

wmic /namespace:\\root\cimv2\TerminalServices PATH Win32_TSGeneralSetting Set SSLCertificateSHA1Hash="THUMBPRINT"

Or if PowerShell is your thing, you can use this instead:

$path = (Get-WmiObject -class "Win32_TSGeneralSetting" -Namespace root\cimv2\terminalservices -Filter "TerminalName='RDP-tcp'").__path
Set-WmiInstance -Path $path -argument @{SSLCertificateSHA1Hash="THUMBPRINT"}

Note: the certificate must be in the 'Personal' Certificate Store for the Computer account.

  • 3
    Just wanted to add that this saved me from pure meltdown. Thank you. Installing the roles and restarting servers as suggested within technet and the like is ridiculous. Even then, once you install the SSL cert in RD Gateway Manager, it doesn't carry over to the remote admin login.
    – Papa
    Commented Feb 12, 2014 at 8:10
  • 2
    Thanks so much for this. I must've searched all of google before I found this. There are too many results telling me to install "Remote Desktop Services" via "Add roles and features", but doing so requires you to join a domain.
    – Sethi
    Commented Mar 12, 2014 at 15:25
  • 2
    If I try to do it using your PS script I get "Invalid Parameter". Same issue if I do it manually, too...
    – deed02392
    Commented Jul 25, 2016 at 15:51
  • 1
    I was getting Invalid argument using all methods until I've re-imported certificate including private keys. Simple mistake.
    – toffitomek
    Commented Jan 12, 2017 at 11:50
  • 2
    Me again :D I'm getting that "Invalid parameter" error in Powershell too when running wmic. Just seen the note at the bottom. Make sure the cert is in the Personal store too. Mine was in the Web Hosting store this time...
    – Sethi
    Commented Jan 31, 2017 at 10:46

If you getting "Invalid Parameter" when you trying Ryan's solution, make sure you are using elevated command prompt (run as administrator).

  • Can't believe this has no upvote! Commented Jun 20, 2018 at 4:21

You need your domain.pfx & the fingerprint in a txt file SSLCertificateSHA1Hash.txt.

Then run this in CMD:

pushd %~dp0

certutil.exe -p "" -importpfx "%~dp0domain.pfx"
set /p FingerPrint=<"%~dp0SSLCertificateSHA1Hash.txt"
wmic /namespace:\\root\CIMV2\TerminalServices PATH Win32_TSGeneralSetting Set SSLCertificateSHA1Hash="%FingerPrint%"
icacls.exe "C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys\*" /grant "NETWORK SERVICE":R
shutdown /r /t 5

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .