I recently upgraded with Solaris patches and after the reboot my Bind Named services go into maintenance mode.

bash-3.2# svcs -xv
svc:/network/dns/server:chroot (?)
 State: maintenance since Thu Nov 01 00:22:19 2012
Reason: Start method failed repeatedly, last exited with status 1.
   See: http://sun.com/msg/SMF-8000-KS
   See: man -M /usr/man -s 1M named
   See: /var/svc/log/network-dns-server:chroot.log
Impact: This service is not running.

Output from var/svc/log/network-dns-server:chroot.log below

[ Nov 1 00:22:19 Executing start method ("/lib/svc/method/dns-server start chroot") ] dns-server: Executing: named -t /var/named/chroot/named -c /etc/named.conf /lib/svc/method/dns-server: named: cannot execute dns-server : start failed! Check syslog for further information. [ Nov 1 00:22:19 Method "start" exited with status 1 ]

As stated I can run named -t /var/named/chroot/named -c /etc/named.conf manually from root and the named process starts and DNS works.

I assume this has something to do with permissions/file ownership or something like that. I have tried changing (chown/chgrp)the /var/named/chroot/named directory to root root and named root. I also did the same with the /var/named/chroot/named/named binary. I also tried the same types of things with the /etc/named.conf file. So far no luck.

Any suggestions on how to figure this out would be greatly appreciated.


Just a wild guess, but I bet 'named' is in your $PATH but not the global $PATH. I would recommend either;

a) Determine the path to named and ensure the path is in /etc/profile

b) Find the spot(s) in the /lib/svc/method/dns-server script and prefix the path to named

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.