In our organization we are running Exchange 2003 and 2010 simultaneously, with the hopes of migrating everyone to Exchange 2010 sometime within the next few months. Everyone is using Outlook 2010.

Recently, we had an issue with transaction log storage on the Exchange 2003 server. This was resolved, but for some reason no meeting rooms on the Exchange 2003 server will automatically book meetings any longer. I have played around with this for a while, changing calendar permissions, turning resource scheduling off and back on, etc. No dice.

My next step was to try migrating a resource to the Exchange 2010 server. After doing so, and setting it up as a Room, enabling Auto-Accept and removing the EnableDirectBooking registry entry on my PC, I can book a meeting with this room. If EnableDirectBooking is enabled, I get an error message stating:

"Meeting Room" declined your meeting because it is recurring. You must book each meeting separately with this resource.

This is despite the fact that the meeting I'm attempting to create has no recurrence.

Now, I have also created a new test Room from scratch on the Exchange 2010 server, and I can book a meeting with this Room regardless of whether or not I have the EnableDirectBooking reg entry in place. All users here have this registry entry, and I'd rather not have to figure out how to push something out to remove it from every PC. Rather, I'd like to figure out what's different between the configurations of these two meeting rooms so that I could book a meeting room regardless of whether EnableDirectBooking is enabled or not.

Any ideas, anyone? Thanks!

1 Answer 1


The reason the migrated mailbox wasn't working was because I hadn't gone into it in Outlook and unticked the resource scheduling stuff in Options > Calendar. Once I did that, the migrated meeting room behaves exactly like the new one, with no need to remove the EnableDirectBooking registry entries.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .