1

I have this error that comes up every time I do an apache2 restart and am just wondering if anyone can shed some light on the issue. Is it something I even need to worry about at all?

I have had it for a while with no problems, but had a server crash recently and while this is obviously unrelated I will be willing to try anything to make sure it doesn't happen again. This includes cleaning up these types of errors to make it easier to troubleshoot in the future.

[Sun Nov 04 10:51:46 2012] [error] python_init: Python version mismatch, expected '2.6.5+', found '2.6.6'.
[Sun Nov 04 10:51:46 2012] [error] python_init: Python executable found '/usr/bin/python'.
[Sun Nov 04 10:51:46 2012] [error] python_init: Python path being used '/usr/lib/python2.6/:/usr/lib/python2.6/plat-linux2:/usr/lib/python2.6/lib-tk:/usr/lib/python2.6/lib-old:/usr/lib/python2.6/lib-dynload'.
[Sun Nov 04 10:51:46 2012] [notice] mod_python: Creating 8 session mutexes based on 256 max processes and 0 max threads.
[Sun Nov 04 10:51:46 2012] [notice] mod_python: using mutex_directory /tmp 
[Sun Nov 04 10:51:46 2012] [notice] Apache/2.2.16 (Debian) DAV/2 SVN/1.6.12 mod_ssl/2.2.16 OpenSSL/0.9.8o mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze14 with Suhosin-Patch mod_python/3.3.1 Python/2.6.6 mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations

Any help will be appreciated, I am a bit of a n00b when it comes to this sort of stuff ;)

1 Answer 1

4

The message is from mod_python, telling you that it was compiled with Python 2.6.5 but the system's Python installation is 2.6.6. It will still work regardless of the version mismatch.

Anyway, mod_python hasn't seen any development in a number of years and has been deprecated by most projects in favour of alternatives like mod_wsgi.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .