1

Trying to send an E-Mail to some stricter set up MXs I get:

<local_hostname>: Helo command rejected: need fully-qualified hostname (in reply 
to RCPT TO command)

Of course, when setting $myhostname in main.cf the Mail gets delivered correctly, but that brings me into conflict with my default virtual hostname being the hostname of the Box itself, and the incoming mails to hostname.org are treated as to be delivered by the LDA, eg. to "local_hostname"

$myorigin and $mydomain didnt seem to change the HELO response either, any suggestions?

1

From an edit to the original question:

http://www.linuxquestions.org/questions/linux-server-73/how-to-map-local-addresses-to-fqdn-addresses-with-postfix-894863/ setting mydestination to " " and then changing $myhostname to the FQDN solved the Problem.

  • Setting $myhostname to the FQDN worked for me. – Ra_ May 26 '14 at 14:14
-2

It has taken me ages to work this out

I am running a centos server and was getting email bouncing back reporting the error" Helo command rejected: need fully-qualified hostname"

I ended up enabling "Reference /etc/mailhelo for outgoing SMTP HELO [?]" This was located under "exim configuration manager" then "Domains and IPS" on the VPS server

Then i used putty and remoted onto the server and ran this command "sudo nano /etc/mailhelo"

In that file i created the domains

example.com: example.com
sub.example.com: example.com
example.net: example.net
addon.example.net: example.net
*: hostname.example.com

(as per http://docs.cpanel.net/twiki/bin/view/AllDocumentation/WHMDocs/EximDifferentIps)

I have tested sending email and all looks good so far

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.