Using Windows Server 2008 R2, I have configured a simple remote desktop access and IIS, then I used my external IP address to ensure that the default IIS web page is reached.

I connected localy to the server using Remote desktop and succeeded. Then, I tried RDP with the same external address used to connect to the IIS and failed. FYI, I am using dynamic-dns.

I have also tried using the domain name: since mydomain.com is both the name of my machine and also the name of my web site, and mydomain.com resolves normaly the IP address.

I have tried to find in Remote desktop Session host configuration in Administrative tools, if is there a way to configure dynamic IP but failed, hard to find on google too.

Is there an idea on this please ?


It sounds like you need to port forward TCP port 3389 to the server in the router/firewall.

| improve this answer | |
  • I already configured the router -> firewall -> Virtual Servers -> fixed local IP address of the server -> to allow the RDP on its port number. You remember the port number changing question ? – Sami-L Nov 6 '12 at 18:16
  • Have you verified that the server is listening on that port for RDS? – joeqwerty Nov 6 '12 at 18:20
  • Yes of course, do you remember Firewall predefined rule question, when it was question to change port number and create a new rule with the new number. – Sami-L Nov 6 '12 at 18:22
  • Yes, but that only addresses the firewall. RDS has to be configured to listen on the port. Have you done that? When you connect internally what port are you connecting to? – joeqwerty Nov 6 '12 at 18:27
  • I have changed the port number in the registry, and I use the same port to connect localy, it works. – Sami-L Nov 6 '12 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.