I have a SAN, and it's able to read and write to the 50TB RAID just fine, but when I run

fdisk -l

it only lists the boot partition of the SAN server, and doesn't display anything about the other partitions on the RAID. I've also tried using

parted -l

with the same result. Now when I type


it shows that the partitions are mounted just fine. I've never seen this happen. The box is running Openfiler 2.3 (I know it's old, we're in the process of upgrading all our old equipment). We have another SAN that's configured almost identically, and it's able to display the partition info with either of the two commands I mentioned above.

  • Are you using iSCSI? – Sven Nov 6 '12 at 21:30
  • No, it's fibre channel – Franklin Nov 13 '12 at 14:31

You can not partition hard disks remotely in the manor. You must have direct access to the block device as to modify the partitioning table you must first unmount it. If you want to repartition the disks use the tools that are appropriate for your SAN. If you are simply after more information about free space and such use df -h

| improve this answer | |
  • It's quite usual in a SAN (e.g. FibreChannel or iSCSI) to see the storage available as block devices which you can indeed partition as you like on the machine that can see it. – Sven Nov 6 '12 at 21:29
  • I'm not trying to partition anything. All I want to do is display all the partitions available to the machine. The Openfiler box is hooked directly up to the RAID. – Franklin Nov 6 '12 at 21:47
  • I edited my question for clarity. – Franklin Nov 6 '12 at 21:53
  • You didn't say anything about iSCSI in your original post SAN could have meant any number of things. Shame about the downvote though :/ – James Park-Watt Nov 6 '12 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.