Using paperclip (3.2.0)

Using polyamorous (0.5.0)

Using pr_geohash (1.0.0)

Using slop (3.3.3)

Using pry (0.9.10)

Using pry-rails (0.2.2)

Gem::RemoteFetcher::FetchError: too many connection resets (http://tokyo-m.rubygems.org/gems/rails-boilerplate-0.1.9.gem) An error occurred while installing rails-boilerplate (0.1.9), and Bundler cannot continue. Make sure that gem install rails-boilerplate -v '0.1.9' succeeds before bundling.

Today, I applied bundle install in my rails directory, but i found out that the mirror where i get the gem rails-boilerplate is not available now? HOw can i modify the references of the mirror? I have tried:

gem install --source http://rubygems.org/downloads rails-boilerplate

but it also failed.


gem install rails-boilerplate -v '0.1.9'

Worked just fine for me. My sources are:

gem sources -l


In general, all stable gem releases should be there even if the project is hosted on Github or elsewhere. If you need to grab a different fork of it or a pre-release version, you may have to specify a different source, but in your case 0.1.0 looks like the current release version. Somehow your gem source is set to fetch from


What do you get when you run

gem sources -l

Since you get the error when installing directly with gem and when running bundle, I assume that the problem is in your default gem sources. You should check the source list with the command above, and alter the list with

gem sources -r SOURCE_URI

to remove, or

gem sources -a SOURCE_URI

to add a new one. I don't know if you should leave the http://tokyo-m.rubygems.org source there or not - it depends on if you have some nonstandard version of a gem installed from there or not. If you do, I would suggest adding that source in your Gemfile, NOT as your gem source. This can be done with something like this:

gem 'prototype_legacy_helper', 
    :git => 'git://github.com/rails/prototype_legacy_helper.git'

in your Gemfile. Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.