3

Operating System: Windows Web Server 2008 R2
Visual SVN Version: 2.5.7
Subversion: 1.7.7
Apache: 2.2.22

I freshly installed the Visual SVN latest version on the server and created one repository in it. In the server management window, it shows that the server is up and running but when I try to browse it in a web browser, it doesn't respond.

I am not able to

  • import my existing code into the repository: Error: Cannot connect to server
  • open/browse the repository with either command localhost:81/svn OR http://www.myserver.com:81/svn OR http:// myIPAddress:81/svn
  • Visual SVN log is clean. The last information in the server log is that "The server is listening to port 81.

3 Answers 3

4

A corrupt Winsock caused similar symptoms on my server (Windows Server 2008 R2 / VisualSVN v2.5.7).

The following command, executed at a command prompt, with a server reboot fixed it.

  • netsh winsock reset

Boy was this a pain.

1

On default page of VisualSVN Server Manager you have clean indication of

  • status of server
  • URL (as active link), on which server can be reached

Server Manager

if you can't reach server at this URL from the same host (preferably), check network connectivity and correctness of hostname

2
  • Thanks Lazy Badger for your response. I also see the server status and running and corresponding server URL. when I click the server URL, it should open up in a web browser, isn't it? In my case, it doesn't happen. The browser fails to connect to the URL. I even tried using IP address. By the way, I am doing these operations on the same machine where the VisualSVN is installed.. Nov 10, 2012 at 23:57
  • 1
    @user1783560 - as I wrote: "check network connectivity and correctness of hostname", even for localhost (tracert, ping, telnet on VisialSVN Server port, netstat -na) Nov 11, 2012 at 0:28
0

There is a knowledge base article on this matter BTW: "Connecting to VisualSVN Server".

All details you've provided indicate that you can't even reach the VisualSVN Server. The Error: Cannot connect to server clearly states that! :) The behavior you describe is definitely caused by some network misconfiguration.

VisualSVN Server works out of the box just after you install it. It does not require any specific steps to be accessible on your LAN or from the Internet.

You should perform the common steps you usually perform to make a web service accessible (e.g. a web server) on your LAN. This leads us to a next troubleshooting step: check network settings and a firewall / proxy etc.

Also you can always contact VisualSVN support for additional troubleshooting.

1
  • Thank you for your response. But I do not know what exact network settings should I check. There is no firewall, no proxy. I am on the server and I just want to import my existing code into freshly created repository and while doing that in the command prompt, it gives me error - Cannot connect to the server. I do not understand, how can command prompt cannot connect to the server when I am on the same machine.. :( Nov 10, 2012 at 23:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.