10

After a fresh install of icinga 1.8 and icinga web I've added a few hosts/services and restarted the icinga service. Next I cleared the cache in icinga web through the web interface by clicking on admin at the top of the screen and clear cache. then reloaded the icinga-web interface and the newly added host/services were not displayed.

The icinga logs do not show any issues, I've also run /etc/init.d/icinga showerrors and no errors or warnings displayed.

I've searched everywhere for a solution and I've read all the documentation from icinga but haven't found any references to this issue anywhere.

1

Please check the whether the web user has access to view the hosts/services that you've added. This can be set using the Icinga roles. For icinga2 have a look at /etc/icingaweb2/roles.ini. The link has more information.

For icinga classic web locate cgi.cgi inside icinga web root and add the new user to authorized_for_* directives wherever you want to allow the user access.

0

Would check indeed if Ido Database is up and running and correctly configured in /etc/icinga2/features-enabled.

Also that might be a case where the database schema has been updated between the 2 versions and you want to run the migration script for MySQL

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.