Paraphrasing this SuperUser link:

When you set up a VPN, the Windows default is to enable "Use default gateway on remote network." A new default route is added to the routing table pointing to the remote network's gateway, and the existing default route has its metric increased to force all Internet traffic to traverse the tunnel and use the remote network's gateway. All traffic uses the VPN, and traffic destined for the outside world is directed to the remote gateway. When the VPN drops, the route to the remote gateway is removed and the original default route is set back to the original metric. Unchecking "use default gateway on remote network" means that new default route isn't added, so Internet traffic goes out the local gateway, but a new classful route is added to the routing table, using the local adapter's IP, pointing down the VPN. Only traffic destined for the classful network of the local adapter goes down the VPN. This may not be what you want. Checking "Disable class based route addition" means that classful route isn't added to your machine when the VPN starts up, and you'll need to add the appropriate routes for networks that should be routed through the tunnel.

But, the option "Disable class based route addition" is available ONLY for Windows 7. How can I do something like that for Windows XP or Vista since they don't have that option? I have searched about for that but, no solution yet.


There is no analog to the Windows 7 functionality in earlier versions of Windows. Your best bet is to disable the "Use default gateway on remote network" and push a route to the clients.

| improve this answer | |
  • I use a fortigate appliance for VPN connections. I was wondering if there is a way to send the routes to client during the moment of connection and avoid windows to create these classful routes automatically. – brgsousa Nov 13 '12 at 12:48
  • You're probably out of luck if the Fortigate appliance insists on being the DHCP server for VPN clients. If it can pull DHCP for VPN clients from another machine then you might have a hope, since you could configure that DHCP server to provide static routes. – Evan Anderson Nov 13 '12 at 15:49
  • You're right. I will try that – brgsousa Nov 13 '12 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.