After an Active Directory fail RDP connection started to ask for credentials twice (once on local RDP program, second time on remote's logon screen)

I already looked at Windows 2008 R2 RDS - Double Login Solution provided there doesn't work for me.

The server is alone, without AD/DNS services, RDP service isn't installed I tried every security settings on RDP-Tcp (RDP, Negotiate, SLL)

Logon option is set to "Use credentials from the client"

Both windows client and server use RDP 7.1

fPromptForPassword regitries are set to 0

Local Computer Policy\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security\Always prompt for password upon connection is set to "Disabled"

Why i am sure the problem comes from the server and not the client ? This problem affected a 3rd RDP program on Android too (it was directly showing "preparing desktop previously, on both MS RDP and the 3rd program)

No bakcup are available (Else the Active Directory wouldn't be a fail, but just a lose of time)

I am wondering if a rule linked to RDP got changed after the AD install+unistall, but i'm unable to find where.

While this is not a critic problem, this is very annoying.

I don't know if more information are needed, if it's the case and if you are patient enough, please tell me what is missing and i'll edit this post to add the missing informations.

  • Is the version of RDP on the server the same as on the client? Have any new updates been applied relating to remote connection security?
    – rws907
    Commented Nov 13, 2012 at 1:56
  • Hello, both client and server use RDP 7.1 Only updated applied was KB2621146 but it's supposed to fix problems with AD and not RDP
    – Zulgrib
    Commented Nov 13, 2012 at 2:47
  • Try this article. I had something similar and it helped me: social.technet.microsoft.com/Forums/en-US/w7itprosecurity/…
    – rws907
    Commented Nov 13, 2012 at 3:29
  • Hello I checked the registry keys and gpedit rules suggested by your link, but it didn't solved the problem ... :-( Edited main post to add info
    – Zulgrib
    Commented Nov 13, 2012 at 3:43
  • Probably unnecessary to ask but have you tried rebooting the server you are attempting to connect to? Or tried restarting the Terminal Server services?
    – rws907
    Commented Nov 13, 2012 at 3:49

2 Answers 2


The problem came from a program conflicting with the logon.

An user management tool designed for Win7 was installed on the Win 2k8r2 computer and the removal of this software made the server behave correctly again.

Thanks rsmith84 for his time, trying to help me, knowing someone take time for you is a great boost to find where is the problem to consume less time from helpers.

  • 2
    No problem. I have noticed a lot of community members would rather troll than provide useful feedback so I try where I can.
    – rws907
    Commented Nov 13, 2012 at 5:13
  • Thank you, thank you, thank you. Jeez, I was about to reinstall the OS because of this quirky behavior.
    – Dae
    Commented Sep 3, 2014 at 17:08
  • Glad it served someone else than me.
    – Zulgrib
    Commented Sep 3, 2014 at 21:10

In my case I had a third party application interfering. I had installed Server 2008 R2 on a Lenovo ThinkPad X200 with a fingerprint reader. The laptop was the RDS Session Host with the problem. Lenovo's reader software for Windows 7 was the culprit, confirmed by disabling fingerprint login and the problem being immediately abated. My assumption is the component tries to display at login and fails, interrupting the automatic login that is underway from when the creds were input into mstsc and 'Connect' was clicked.

I have not played with potential solutions, like other ones meant for newer Windows versions.

(Hate to duplicate an answer, but without 50 reputation I can't add this as a comment to the above answer.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .