I've got a dual 1.33GHz G4 Xserve running Mac OS X 10.5.2 Server (I'll try upgrading to 10.5.7 shortly) with two Gigabit Ethernet NICs that is a backup storage server. I attempted to configure it for Link Aggregation with our Netgear GSM7224 (running firmware, current) Gigabit switch, but was unsuccessful. Never done this before, so I'm probably missing something obvious.

I plugged the two GigE NICs into ports 7 & 8 on the GSM7224, set static IPs (.21 & .22 in my subnet) on the them, then created a Link Aggregation port (bond0) w/static IP (.149, the original static IP of the primary NIC) using System Preferences. bond0 listed as down, saying there were no peers.

After verifying that the GSM7224 supports 802.3ad (LACP) Link Aggregation in the specs and going through the admin interface to verify that it listed LACP as "enabled" on ports 7 & 8, I discovered that System -> Switch -> Port Channel -> Configuration allowed me to manually create what I think are Link Aggregation Groups (LAGs). I configured one for ports 7 & 8 w/link trap enabled, administration enabled, STP mode enabled, and Static mode disabled. This got bond0 to show as up and I was able to ping the static IP (.149), but no other traffic would flow.

I tried changing the static IP of bond0 to .20, setting both NICs and bond0 to .20, and nothing allowed more than a ping to get through. Ended up removing the Port Channel, deleting bond0, and reverted the primary NIC back to a static IP of .149.

I checked the GSM7224 documentation and the only info about Link Aggregation explained how to create a Port Channel as I had done. Also, the Mac OS X Server documentation was extremely dumbed down and only explains how to add the Link Aggregation port, nothing about requirements or anything like that.

Some notes I found through Google implied I should not config the switch to aggregate the two ports when using Mac OS X Server's Link Aggregation. This comment on another serverfault question seems to imply that I had configured a LAG, but I think I covered everything that it mentions (and would've been helpful before I got as far as I did by trial and error).

What do I need to do to get Link Aggregation working between the Xserve and GSM7224? I have another file server that should get Link Aggregation on this switch as well.

  • Not much help - but with an original 1Ghz G4 Xserve I wasn't able to get LACP to work at all running Tiger. Newer Xserves worked fine the the GSM7224 however. – Chealion Jul 24 '09 at 15:23
  • Hmmm, I'll see if I can grab on of our Intel Xserves for testing and see if it works there. – morgant Jul 24 '09 at 19:01

Not much direct help I'm sure but there'll be no need for giving each link it's own IP address, LACP is a layer-2 thing so they'll only need one IP for the pair.

| improve this answer | |
  • 1
    Good to know. I figured that might be the case, hence at least trying it with en0, en1, and bond0 all set to the same IP. Have to give them some IP otherwise bond0 is listed as down because the included ports aren't connected. – morgant Jul 24 '09 at 11:13

I gave up this problem long ago. I was able to get link aggregation working with this switch and an Xserve G5 (so dual built-in GigE ports) running Snow Leopard Server, so I believe that it's an issue with G4 Xserves.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.