I have this problem on mounting a logical volume. I have done some research and still have not found solution. I have read this https://superuser.com/questions/116617/how-to-mount-lvm-volume also but I can't figure out. Here is the my situation we have server that has 500GB disk. Later on we decided to add 1TB disk since we need more to store our data. We configure the first disk to extend the second disk using the logical volume. Now, we upgraded our server specs with higher processor and ram. We now have a new disk with 2TB with the OS installed. We also need to copy some xml files and database data from the two disk before which are attached now on the server. My problem would be how to mount this two disk? Am i going to mount it individually or mount on the the logical volume? I'm really new to this server configurations. Hope somebody could help me out.

Here are additional info:

When I run fdisk -l, this is the result

Disk /dev/sda: 2000.3 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14        1058     8393962+  82  Linux swap / Solaris
/dev/sda3            1059        7457    51399967+  83  Linux

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          13      104391   83  Linux
/dev/sdb2              14       60801   488279610   8e  Linux LVM

Disk /dev/sdc: 1500.3 GB, 1500301910016 bytes
255 heads, 63 sectors/track, 182401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

When i run mount, this is the result

/dev/sda3 on / type ext3 (rw,usrquota,grpquota)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)

When I run pvs, this is the result

   PV         VG   Fmt  Attr   PSize   PFree  
  /dev/sdb2       lvm2   a--   465.66G 465.66G
  /dev/sdc        lvm2   a--   1.36T   1.36T

When I run pvscan, this is the result

PV /dev/sdb2                      lvm2 [465.66 GB]
PV /dev/sdc                       lvm2 [1.36 TB]
Total: 2 [1.82 TB] / in use: 0 [0   ] / in no VG: 2 [1.82 TB]

I would appreciate any help. Thanks

  • 1
    What do you get when you run lvs? And ls -la /dev/mapper? – MadHatter Nov 14 '12 at 14:36
  • I got "No volumes found". As with the pvs, the VG field is empty. Thanks for the response. – Jan Mark Nov 14 '12 at 14:38
  • I got this one for ls -la /dev/mapper drwxr-xr-x 2 root root 60 Nov 13 03:40 . drwxr-xr-x 12 root root 3660 Nov 13 03:41 .. crw------- 1 root root 10, 60 Nov 13 03:40 control – Jan Mark Nov 14 '12 at 14:40

You haven't actually created any volume groups or logical volumes!

Create some with:

vgcreate porn /dev/sdb2 /dev/sdc
lvcreate /dev/porn -L 1TB -n data
mkfs.xfs /dev/porn/data
mount /dev/porn/data /export/porn
  • Actually, we have created volume groups and logical volumes before we upgraded our server as stated above on the question. However, the two drives which are part of logical volumes where move as secondary disk because the new set up was installed on a new hard disk. – Jan Mark Nov 14 '12 at 14:57
  • 2
    With respect to the mkfs.xfs /dev/porn/data, is not that going to delete the data on volume group? I have important data which I need to transfer to the new disk. Thanks. – Jan Mark Nov 14 '12 at 15:00
  • 2
    You think you have data on /dev/sdb2 or /dev/sdc? Not anymore, you don't. – MikeyB Nov 14 '12 at 15:56
  • @JanMark The information posted above explicitly states there are no volume groups or logical volumes on the drives. You'll have to restore from backup. – Chris S Nov 14 '12 at 16:18
  • 3
    The pvs output you post above shows that those disks do not contain any LVM data. You've done something (pvcreate?) that wiped them out. At this point, you need to recover from backup or contact a consultant to get them to help recover your data if you have no backups. – MikeyB Nov 15 '12 at 14:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.