0

I have several websites that use Telerik controls and need to install the assemblies to a new VM running Windows Server 2008 R2. Normally I would drag the *.dll straight into the C:\Windows\Assembly folder, but I'm getting faced with an "Access Denied" error.

From what I've read, you can overcome this by logging into the local Administrator account, however I cannot RDP into this account. (Actually I can, I was wrong)

What is the easiest way to install these assemblies? Gacutil?

EDIT: I should also add, it is best if the solution does not involve disabling the UAC or restarting the server. I would like to avoid service interruption if possible.

6
  • I think this probably needs to move to Stack Overflow. Also, I have read this question a few times now, and I'm sorry, but it sounds to me like you're asking "why am I not able to do something that I do not have permissions/privilege to do?" Sort out the permissions with your administrator.
    – Ryan Ries
    Nov 15 '12 at 20:42
  • @RyanRies I AM the Administrator!
    – Chiramisu
    Nov 15 '12 at 20:45
  • You're the admin but you can't use your own credentials to do this?
    – gparent
    Nov 15 '12 at 20:47
  • Oh... I get it. I bet it's a domain-joined machine and local admin account is disabled.
    – Ryan Ries
    Nov 15 '12 at 20:49
  • @gparent I am a member of the Administrators group, however I cannot login as the local Administrator account on the VM via RDP! Gosh, read peeps.
    – Chiramisu
    Nov 15 '12 at 20:49
0

As it turns out I was indeed able to RDP into the machine as the local Administrator account. For the benefit of those who read this later, both my machine and the server are on a domain controller and my account is in the Administrators group, but that was not enough.

To add Assemblies, I simply followed the standard convention of opening two Explorer windows, one at C:\Windows\assembly and the other where my DLLs are, then drag the DLLs into my assembly folder. Windows takes care of the rest.

To connect login to the server in such a way as to make this possible, I had to RDP using the following credentials since it's on a domain.

  • Computer =[server_name]
  • User name=[server_name]\Administrator
4
  • "As it turns out I was indeed able to RDP into the machine as the local Administrator account." You're such a troll.
    – Ryan Ries
    Nov 16 '12 at 1:14
  • @RyanRies Wow, that was completely uncalled for. I was told I shouldn't delete my questions, otherwise I would have since I was wrong to begin with. I figured I'd at least post a helpful answer to explain I was wrong. Who's the troll?
    – Chiramisu
    Nov 16 '12 at 1:16
  • 2
    I wasn't trying to actually offend you... I was trying to be funny. Sorry.
    – Ryan Ries
    Nov 16 '12 at 1:20
  • @RyanRies Oh, lol, gotcha, hehe. My bad. :P
    – Chiramisu
    Nov 16 '12 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.