1

I am trying to enable automatic logon in Windows Server 2012 Core (no GUI). I followed the instructions that i have been following for years, detailed in this Microsoft Support KB, but auto login is not working.

It works fine for Server 2012, with GUI, but not on Core.

For curious minds: I enable auto login it saves me time it's my lab, and isolated, so I don't have to worry about security.

  • 1
    Did it work for 2008R2 core? – SpacemanSpiff Nov 17 '12 at 1:51
  • i am not familiar with 2008R2 Core. i have only used 2008 R2 GUI – hpsoftware Nov 17 '12 at 14:23
1

You can always play with command line and add the following registry keys:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\winlogon

Create following keys:

AutoAdminLogon = 1
DefaultUsername = currentUserName
DefaultPassword = currentPassword
0

You can use Autologon tool from Sysinternals http://technet.microsoft.com/en-us/sysinternals/bb963905 - or direct link: http://live.sysinternals.com/Autologon.exe

Tested on Hyper-V Server Core 2012 R2 (RTM)

-1

Open cmd or powershell and type: control userpasswords2

Select Administrator type password and that's it.

  • 1
    "Windows cannot find 'C:\Windows\system32\netplwiz.exe'. Make sure you types the name correctly, and then try again. – Chris S Sep 30 '14 at 18:22
  • OP is asking about server core – squillman Sep 30 '14 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.