22

Anyone know of a way to completely wipe WSUS of updates and start again?

It seems as if I have loads of language packs and assorted rubbish in the list which we do not need. Having now removed all the unwanted Products, Classifications and Languages what I would like to do is completely clean out the WSUS database and start again. It appears that uninstalling the reinstalling the WSUS role does not help they are all still there. Have also tried the Server Cleanup wizard which seems to be mostly a waste of time, it didn't clean up any of the updates I was hoping it would remove.

I haven't yet installed any of these on a machines yet so if only I could work out how I could completely wipe all listed updates and start again but according to my new reduced Products list.

Thanks, Nick

  • I have a feeling that WSUS 2012 is just ignoring my Product, Classification & Language settings and listing whatever downloads it want to ignoring my settings. – NickC Nov 18 '12 at 21:06
19

To re-install WSUS with a clean database i.e. no previous configuration:

Run Windows Powershell as Administrator and use the following commands:

  • Uninstall-WindowsFeature -Name UpdateServices,Windows-Internal-Database -Restart

  • Post restart, delete EVERYTHING in the C:\Windows\WID\ (for Win 2012 r2) folder.

  • Then run the following command to re-install WSUS:

    Install-WindowsFeature UpdateServices -Restart
    

This only works on PowerShell 3 or higher.
More info here: Microsoft TechNet: Removing Server Roles and Features

  • The uninstall worked well. The power shell install did not add the database back for me (the non SQL Server version). I ended up using the power shell command to uninstall, then the server manager add wizard to re-install. – pStan Feb 7 '17 at 4:02
  • Watch out for the -Restart flag and make sure you are actually ready to restart the entire physical or virtual server. – jdgregson Apr 13 '17 at 1:29
  • "I solved this issue by opening IIS Manager and deleting the old WSUS web site, then running the Complete WSUS Installation again." -mshorroshAvanade (Partner) social.technet.microsoft.com/Forums/windowsserver/en-US/… – Spencer5051 Aug 9 '17 at 21:47
10

Answer now found, just posting this for the benefit of anyone else who might come across this problem.

It seems that uninstalling WSUS and WID Database option does not actually remove the WID database.

  • The WID database can be removed by uninstalling the Windows Internal Database feature.

  • You will also need to manually delete the file C:\windows\WID\Data\susdb.mdf before re-installing everything again.

  • above does not work. I am using windows powershell on server 2003. – user242086 Sep 12 '14 at 13:15
  • 1
    Deleting the susdb.mdf-File will result in errors during post-installation-configuration, until the file is restored manualy. – Tobias Sep 28 '15 at 12:47
  • What Tobias said. Does not work for 2012r2. – StackzOfZtuff Sep 13 '16 at 10:07
  • WID is an internal database server that may be used for other things, so completely removing it could kill other services. For example, on a Windows 2016 Server running the Essentials role, besides the SUSDB, there is also a RaAcctDb database. Safer to use the official instructions in @StackzOfZtuff's answer, which only deletes the SUSDB. – Mark Berry Oct 20 '18 at 17:56
7

Use official instructions

There is now an official blog post out:

This is my unofficial summary of the official blog post:

  1. stop-service WSUSService, W3SVC
  2. connect with SQL Server Management Studio (SSMS).
  3. Use SSMS to backup SUSDB
  4. Use SSMS to delete SUSDB
  5. Rename content directory
  6. Recreate content directory
  7. start-service WSUSService, W3SVC
  8. Run Program Files\Update Services\Tools.Wsusutil.exe postinstall (see blog for command line parameters)
  9. Done.

For WS2012/WS2012R2: Connecting to the Windows Internal Database requires the use of a Named Pipes connection. The connection string you want is:

\.\pipe\MICROSOFT##WID\tsql\query

For WS2003/WS2008/WS2008R2: Connecting to the Windows Internal Database requires the use of a Named Pipes connection. The connection string you want is:

\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query

protected by Community Sep 8 '15 at 17:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.