1

I have two machines and I'd like their clocks to be in sync for various reasons. Machine 1 is an XP machine located in the office. Machine 2 is a VPS hosted by a third party running Windows Server 2008 R2. These machines are not in any kind of workgroup or on a domain together. They are completely separate machines.

Machine 2 is currently syncing once a week to time.windows.com. The clock on Machine 2 does seem to wander a bit within that week interval. What I would like to do is have Machine 1 set its clock based on the clock of Machine 2.

I have tried configuring w32tm on the XP machine. This is what I used for configuration:

w32tm /config /syncfromflags:manual /manualpeerlist:"<ip address of machine 2>"

However, whenever I issue the /resync command I get "The computer did not resync because no time data was available". I have made sure to start the windows time service on machine 2, and I have added firewall exceptions for UDP port 123.

Is there something I need to configure on Machine 2 (other than just starting the time service) in order to get it to respond?

Edit: I have also run w32tm /config /reliable:YES /update on Machine 2. I am still getting "The computer did not resync because no time data was available". Is there something else I'm missing?

Edit 2: The solution I used was most closely related to the answer I marked as correct. However, this article offered additional registry tweaks that worked in my case: http://www.articlesbase.com/networks-articles/how-to-configure-windows-server-as-a-ntp-server-108481.html

  • Are either machines a member of any AD domain, even if they're not in the same one? – MDMarra Nov 19 '12 at 19:33
  • If the clock skews during the week you can set a polling interval (mdmarra has discussed this in the past). Another option would be to set both to use the same 3rd party source. – TheCleaner Nov 19 '12 at 19:40
  • @MDMarra Unfortunately no - just two independent machines :( – Eric Nov 19 '12 at 21:34
  • That's actually better for your needs in this case. At least as it related to time services. – MDMarra Nov 19 '12 at 22:07
3

Machine 2 needs to be confiugred as an authoritative time source. Ie. NTPSERVER = 1. From the registry key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\W32Time\TimeProviders\NtpServer] Enabled = 1

Alternatively you can do that via the command w32tm /config /reliable:YES /update

| improve this answer | |
  • I just tried this, and it didn't seem to work. Somewhere along the way I saw some text saying that /reliable:YES was only valid for domain controllers? Unfortunately these machines are not on any domain or workgroup, just standalone machines – Eric Nov 19 '12 at 22:17
  • 1
    I'm marking this as correct, as this was part of the solution. However, I needed to change the AnnounceFlags as well. This url solved my problem: articlesbase.com/networks-articles/… – Eric Nov 19 '12 at 23:45
3

There are also some good ports of NTP reference code that I like to use on Windows machines. Look at

  http://www.meinbergglobal.com/english/sw/ntp.htm#ntp_nt_stable 
| improve this answer | |
2

"The W32Time service is not a full-featured NTP solution that meets time-sensitive application needs."

I would switch to a standard NTP service. Some hints here http://www.satsignal.eu/ntp/setup.html

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.