I've been updating my amazon ec2 micro instance every month till now. when i try to "yum update" i receive this error :

zlib-1.2.5-7.11.amzn1.x86_64 has installed conflicts libxml2 < ('0', '2.7.7', None): libxml2-2.7.6-4.12.amzn1.x86_64

zlib-1.2.5-7.11.amzn1.x86_64 is a duplicate with zlib-1.2.3-27.9.amzn1.x86_64

yum update output: http://pastebin.com/Dfq0yphN

I've tried to update separately zlib and libxml2

  • zlib: same "duplicate" error.

  • libxml2: Transaction Check Error: package libxml2-2.7.8-10.24.amzn1.x86_64 is already installed

what can i do?

  • 1
    I wouldn't use "Amazon Linux." From everything I've seen it's incredibly buggy, and this sort of thing happens all the time. – Michael Hampton Nov 20 '12 at 23:24

Solved by yum erase'ing all duplicate/obsolete packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.