In a domain, I want to set DC as time server.

To do that I use this command:

w32tm /config /manualpeerlist:europe.pool.ntp.org /syncfromflags:manual /reliable:yes /update


w32tm /resync /rediscover

In the client servers I use

net time \\<comp.name.of.ad> /set /y 

but some of the clients still use Local CMS Clock.

What can I do?

Thanks in advance.


I also run

w32tm /resync [/computer:<computer>] [/nowait] [/rediscover]

on client end but the time server is still Local CMOS Clock for the client.

On the AD source is what I set. (nist.expertssmi.com)

On the clientend, source is Local CMOS Clock

  • What is the output of the w32tm /status and is the DC advertising as a time server? See serverfault.com/a/449832/20701
    – Greg Askew
    Nov 22, 2012 at 11:40
  • Have you tried this from the client end - w32tm /resync [/computer:<computer>] [/nowait] [/rediscover] Nov 22, 2012 at 11:40
  • Did you stop and restart the time service by running this command? net stop w32time && net start w32time
    – Sam Erde
    Nov 23, 2012 at 12:25
  • Do you have more rhan one domain controller? The time server needs to have the PDC FSMO role.
    – Spencer
    Sep 1 at 23:10

3 Answers 3


To configure a client computer or a member server to sync time from the domain, run the following command:

w32tm /config /syncfromflags:domhier /update

And then stop and restart the time service by running:

net stop w32time && net start w32time

This should be all you need to do.

  • 2
    This did not work for me. Ran the above commands as admin: The command completed successfully., The Windows Time service was stopped successfully., The Windows Time service was started successfully. Still, Time Server: Local CMOS Clock.
    – bers
    Oct 9, 2020 at 8:52
  • Is this on a VM? If so, which hypervisor?
    – Sam Erde
    Oct 9, 2020 at 14:37
  • No, this was on a regular Laptop. Windows 10 is installed, but has not seen the domain server except over limited Cisco VPN in 7 months (Corona). Maybe that's part of the reason. I was able to set pool.ntp.org servers using a similar w32tm command, but syncing still fails.
    – bers
    Oct 9, 2020 at 19:14
  • The given problem and solution only are relevant for computers that are joined to a domain.
    – Sam Erde
    Oct 10, 2020 at 1:53
  • 1
    Fair point, but still, if your computer is rarely connected to a domain where it can sync its time with a domain controller, then it is gradually going to drift out of sync with the domain anyway. In a situation where the computer rarely syncs with the domain, you may be better off skipping domhier and just configuring win32time to use an internet-based time service.
    – Sam Erde
    Oct 10, 2020 at 13:23

I went thru all the above on my domain joined Windows 10 machine trying to get it to resync. What fixed this for me was I first ran DCDIAG on my domain controller and saw the error that said this server is not advertising as a time server. So then I ran w32tm /query /status on my DC. Which returned an answer of vmnic something. My DC was using the time integration services from the Hyper-V host. I went to the Hyper V Manager and went to the setting on my DC and removed the check box from time integration services. Then I reset my DC to use an external time source:

w32tm /config /manualpeerlist:time2.google.com /syncfromflags:manual /reliable:yes /update 
net stop w32time && net start w32time

Now when I went back to my Windows 10 clients I could run:

w32tm /config /syncfromflags:domhier /update
net stop w32time && net start w32time

That fixed the time sync immediately. After about 15 minutes the rest of my domain joined PC's had also updated to the correct time. Hope this helps you!


I had the same problems, but the suggestions above didn't help (w32tm /resync brought "The computer did not resync because no time data was available"). Until I found out that there was no secure channel to the DC (tested with nltest /sc_verify:<domain name>), and the cause was that the machine account password didn't work. I fixed that with Reset-ComputerMachinePassword -Server "<dc-name>" -Credential <domain admin account> in a Powershell. Now the w32tm /query /source showed that time was received from the DC, and not from CMOS clock anymore.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .