7

In a domain, I want to set DC as time server.

To do that I use this command:

w32tm /config /manualpeerlist:europe.pool.ntp.org /syncfromflags:manual /reliable:yes /update

and

w32tm /resync /rediscover

In the client servers I use

net time \\<comp.name.of.ad> /set /y 

but some of the clients still use Local CMS Clock.

What can I do?

Thanks in advance.

Edit:

I also run

w32tm /resync [/computer:<computer>] [/nowait] [/rediscover]

on client end but the time server is still Local CMOS Clock for the client.

On the AD source is what I set. (nist.expertssmi.com)

On the clientend, source is Local CMOS Clock

  • What is the output of the w32tm /status and is the DC advertising as a time server? See serverfault.com/a/449832/20701 – Greg Askew Nov 22 '12 at 11:40
  • Have you tried this from the client end - w32tm /resync [/computer:<computer>] [/nowait] [/rediscover] – ServerFaulter Nov 22 '12 at 11:40
  • Did you stop and restart the time service by running this command? net stop w32time && net start w32time – SturdyErde Nov 23 '12 at 12:25
7

To configure a client computer or a member server to sync time from the domain, run the following command:

w32tm /config /syncfromflags:domhier /update

And then stop and restart the time service by running:

net stop w32time && net start w32time

This should be all you need to do.

| improve this answer | |
  • This did not work for me. Ran the above commands as admin: The command completed successfully., The Windows Time service was stopped successfully., The Windows Time service was started successfully. Still, Time Server: Local CMOS Clock. – bers Oct 9 at 8:52
  • Is this on a VM? If so, which hypervisor? – SturdyErde Oct 9 at 14:37
  • No, this was on a regular Laptop. Windows 10 is installed, but has not seen the domain server except over limited Cisco VPN in 7 months (Corona). Maybe that's part of the reason. I was able to set pool.ntp.org servers using a similar w32tm command, but syncing still fails. – bers Oct 9 at 19:14
  • The given problem and solution only are relevant for computers that are joined to a domain. – SturdyErde Oct 10 at 1:53
  • The computer in question is joined to a domain. It just hasn't seen the domain controller in a while (but I am still not sure that is why this command has no effect). – bers Oct 10 at 5:56
0

I went thru all the above on my domain joined Windows 10 machine trying to get it to resync. What fixed this for me was I first ran DCDIAG on my domain controller and saw the error that said this server is not advertising as a time server. So then I ran w32tm /query /status on my DC. Which returned an answer of vmnic something. My DC was using the time integration services from the Hyper-V host. I went to the Hyper V Manager and went to the setting on my DC and removed the check box from time integration services. Then I reset my DC to use an external time source: w32tm /config /manualpeerlist:time2.google.com /syncfromflags:manual /reliable:yes /update Then run: net stop w32time and net start w32time Now when I went back to my Windows 10 clients I could run: w32tm /config /syncfromflags:domhier /update and net stop w32time and then net start w32time That fixed the time sync immediately. After about 15 minutes the rest of my domain joined PC's had also updated to the correct time. Hope this helps you!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.