2

I'm trying to connect my access front-end to the SQL Server backend.

It was working when SQL Server was on my computer but now i'm trying to connect to a server

So when I create the DSN file with access

  1. I chose SQL-Server driver ( I have also tried with SQL-Server native 10.0 )
  2. I enter the server name that I copied from SQL Management Studio so there's no typo there
  3. I chose the NT authentication

Then I have this error

enter image description here

In the properties, I tried with TCP/IP with the default port 1433 and I also tried with the name pipes

I made sure that the checkbox to allow remote connection is checked

If I try to connect with management studio I can see the server when I browse on the network but I got this error

enter image description here

I'm trying this troubleshotting but i'm stuck with the telnet command. It says Could not open connection to host on 1433

I also tried with no port and i got the same error on port 23

Any ideas?

Thank you

1 Answer 1

2

For SQL Server Express, remote connections are not allowed by default. Have you enabled them?

See https://stackoverflow.com/questions/11278114/enable-remote-connections-for-sql-server-express-2012

2
  • After 2 days on this, thank you so much!!! I thought that blank was for the default port which is 1433
    – Marc
    Nov 22, 2012 at 20:03
  • Computers, eh? You know what you know, and there's no shame in asking... Nov 22, 2012 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.