I've setup a shared mailbox on our Exchange 2010/SBS2011 server. I've added some users as Full permission-users on this mailbox, and when they open Outlook/login to OWA the mailbox is automatically opened. Great stuff.

However, only the Inbox folder is visible, and the alternative to create a folder is grayed out. If they open the mailbox explicitly (for instance in OWA by clicking open other user's mailbox) they can see other folders, as well as create new ones. What configuration is needed to be able to view and create subfolders directly?


You can give permissions on Inbox folder directly. It doesn't matter - shared mailbox it is or user mailbox. Add Full permission for this folder to yourself. Open the Inbox Folder properties - Permissions Tab.Choose the user and Check the checkbox Create Subfolder. If you want to make the Subfolder visible - Open the Permission Tab of subfolder and check the Folder visible parameter.

Or you can use Set-MailboxFolderPermission cmdlet in powershell.


You can set the inheritance type of the permissions as described in this document:

The InheritanceType parameter specifies whether permissions are inherited by folders within the mailbox.

The options for this parameter can be seen here. This appears to be the default, at least in our environment. To check if this is relevant to your scenario, you can do

Get-MailboxPermission <MailboxIdentity> | ft User,InheritanceType

to see what the InheritanceType flag is set to for your permissions entries on that shared mailbox. If they're not set to All then you may need to remove and re-add the permissions using

Add-MailboxPermission -Identity "Ellen Adams" -User KevinKelly -AccessRights FullAccess -InheritanceType All

as an example.

The other thing we have had problems with is adding users to shared mailboxes directly. If you create a mail-enabled security group for that mailbox, grant it FullAccess to the mailbox and then add users to the security group, you may get better results.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.