There are many discussions about glibc on CentOS on serverfault but I couldn't find one directly related to these: I have CentOS 5.8 server and I would like to install G-WAN. It requires GLIBC 2.6, I have 2.5 right now.

Does CentOS 5.8 support GLIBC 2.6 or do I have to upgrade to CentOS 6? Is there a documentation about these requirements?



The discussions you may have seen are correct...
See here, here, here, and here.

You can't change glibc versions on CentOS 5. You'll need an upgrade to a newer version of RHEL/CentOS.

EL6 ships with glibc 2.12:

Name        : glibc                        Relocations: (not relocatable)
Version     : 2.12                              Vendor: CentOS

Of course, upgrading CentOS versions isn't particularly easy...

| improve this answer | |
  • Foo. They just make it sound hard so we can charge exorbitant consulting rates for doing it and making it look easy. – Michael Hampton Nov 23 '12 at 0:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.