We've been using Server2008R2 with Hyper-V for a couple of years now and chose it at the time because of its ability to make use of Intel SpeedStep and AMD PowerNow! Now with Server 2012 and Hyper-V V3, all power management abilities seem to be gone. The CPUs are always at full speed and our servers need twice the energy as before while idling. (Yes, the CPU P-states are enabled in the BIOS) Is this by design? Is there a workaround to enable cpu power management again? Despite the great new features of Hyper-V 3, this would be a show-stopper for us since we are very concerned about energy consumption.

  • so if you open an elevated powershell prompt and run the following "gwmi -comp pies085 -NS root\cimv2\power -Class win32_PowerPlan | select ElementName, IsActive | ft -a" what do you see. – tony roth Nov 28 '12 at 22:04
  • Unfortunately, I cannot execute gwmi on the server. I receive a RPC server exception 0x800706BA. Tried to disable the firewall and checked the RPC service with no change. Powershell run with Admin privileges. – Roland Dec 14 '12 at 7:46

Have you looked at you power plan settings? I believe if you have it set to High Performance, the CPUs are never parked and therefore always consuming maximum power. Perhaps you can switch to Balanced or a Custom level that allows for power savings features to be enabled.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.