Exchange 2010 SP1 Update Rollup 5 server information store database was restored to a Recovery Database using EMC Networker successfully. The Recovery Database is in a mounted state with mailboxes listed within in it.

  • However, when restoring the mailbox content using the following command:

Restore-Mailbox –Identity MYMAILBOX –RecoveryDatabase MYRECOVERYDB –RecoveryMailbox LOSTMAILBOX –TargetFolder FOLDERFORLOSTMAILBOX

Returns the following error:

Mailbox "LOSTMAILBOX" doesn't exist on database "MYRECOVERYDB".
    + CategoryInfo          : NotSpecified: (0:Int32) [Restore-Mailbox], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : 66265C53,Microsoft.Exchange.Management.RecipientTasks.RestoreMailbox

Note: I've used the correct alias name for the mailbox name; I've also tried combinations such as first name, or last name or both and so forth.

  • Issuing a Get-MailboxStatistics -Database MYRECOVERYDB to see if the mailbox is there and it is as shown below:
DisplayName               ItemCount    StorageLimitStatus

LOSTMAILBOX              39495           MailboxDisabled

Note: The StorageLimitStatus shows a strange output of MailboxDisabled. Perhaps this may be the culprit.

Going by the article's documentation I cannot complete the restore of the mailbox as I'm stuck at the restore-mailbox error that it cannot be found.

Please advise.

Source of article: http://www.testlabs.se/blog/2012/07/05/exchange-2010-restore-to-recovery-database-using-emc-networker/


Note that for Restore-Mailbox you should be using the DisplayName as reported by

Get-MailboxStatistics -Database MYRECOVERYDB

as the parameter to -RecoveryMailbox. If the DisplayName contains spaces, you have to enclose it in quote signs ("Lost Mailbox").

The "MailboxDisabled" storage limit status should not prevent you from retrieving data off the mailbox, it just is a status set when mailbox storage limits are exceeded. If you are concerned by this, you should be able to change the limits by running Set-Mailbox with the -ProhibitSendQuota and ProhibitReceiveQuota parameters and waiting a bit (the information store caches this information and refreshes it every 2 hours, so it might take that long for your change to show).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.