In my setup, I have a FreeBSD (soon to be Debian) server hosting multiple working samba shares. I access these shares from my Windows 7 laptop and Ubuntu 12.10 desktop, all on the same LAN segment. I can mount and use the shares without any trouble. However, my server machine does not show up under "Network Devices" under Win7 or Ubuntu. Which Samba or other settings must I adjust to make the machine visible to the network, both on Windows 7 and Ubuntu?

I've read the docs, but I'm still confused.

Edit: I have NO idea what WINS is or does. Clarification on this point would be appreciated. I want to access my server by a hostname... do I need DNS or WINS?

  • I know its a n00b question, but I'd rather have a concise, succinct answer instead of fumbling through the docs – parker.sikand Nov 26 '12 at 8:06

I'm still working through these issues myself. My understanding at this point is that your fundamental problem is that, without some centralised system to recognise namings, there's no way to identify devices by their names.

In the case of just standard hostname resolution for something like a ping, you actually need a local DNS to resolve your host names to IP addresses.

It seems that different protocols have their own ways around this. I think Windows goes through a network discovery process (like a broadcast and response or maybe even IP scanning) and thus discovers devices that way. I'm able to see my Debian Samba share by the hosts name on my Windows network, and I haven't set up a DNS or WINS.

But I think that simplistic config runs into problems. I can't ping my Debian device by its hostname, for example. And I assume at some point Windows may get all confused.

Setting up a local DNS is the ultimate solution (which I plan to do eventually). It looks like WINS is an alternative solution (not mutually exclusive), that offers basically the same thing. The advantage is that it looks like it's relatively easy to set up your Samba server as a WINS server. But I haven't looked into how.


A couple things need to happen to allow browsing to work:

  • The workgroup (or domain if you're running one but it doesn't sound like it) should be common across all devices. (workgroup = line in the smb.conf file). This is not required, but it definitely makes things easier.
  • The nmb service needs to be running and not firewalled.

Since you have a working samba, once you've taken care of these simple things, it should Just Work.


For what it's worth, I simply turned ON the WINS server option in smb.conf and things now work as I wanted. My machine and its workgroup show up around my LAN both on both other linux and Windoze devices.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.