I'm working with:

  • Two new ESX servers that I'm configuring
  • A new Server 2008 R2 machine that I'm using for vCenter.

I took the following steps:

  • Installed the Hypervisor on the 2 ESX machines
  • Checked their setup/connectivity (appears to be fine; can ping, etc.)
  • Installed vCenter Server on the Win2k8R2 box. This included the install of a SQL Express database (we're a small shop)
    • FYI, I changed some of the ports (443 --> 8443, 80 -->8080, etc.)
  • Installed vCenter Web Client Server on the Win2k8R2 box


  • my vSphere Client on my Desktop fails to connect. Part of this is that it asks me for a username and password, but I don't recall specifying one when I set up the install.
    • I receive the error "vSphere Client could not connect to [machinename]. An unknown connection error occurred. (The request failed because of a connection failure. (Unable to connect to the remote server))"
    • I have also tried to use local machine admin credentials, including the format machinename\localuseracct.
    • I have also tried using my domain credentials which are an admin for that box.
    • I have also checked and the service is running.
    • I also tried to connect via vSphere client locally installed on the server. It translates "localhost" to the correct name but gives the same error.
  • I cannot register the vCenter server from the vCenter Web Client Server. I'm not sure if this is necessary, as they're both on the same machine, but it seems like the logical next step. I also receive a "failed to connect" error in this case as well.
    • FYI, both the vCenter server and the vCenter Web Client Server are installed on the same Win2k8R2 server.

What am I missing here? What is the best way to test in this case?

  • 5
    Have you had any training? Most courses cover these topics straight away and would prove an invaluable basis for evaluating and implementing VMware products.
    – Chopper3
    Nov 26, 2012 at 15:56
  • 1
    you've checked that the windows firewall isn't blocking the connections, right?
    – Rob Moir
    Nov 26, 2012 at 15:56
  • @Chopper3, Unfortunately no, other than beginning to pour over the guides just now. Nov 26, 2012 at 15:58
  • @RobM, Windows Firewall is turned off but we've got Symantec Endpoint Protection on there and that's a fair point. I'm in the process of getting the domain admins to check that out (nothing in the logs but can't be sure). Nov 26, 2012 at 15:59
  • 2
    well if you've changed the default ports then those ports need to be unblocked...
    – Rob Moir
    Nov 26, 2012 at 15:59

1 Answer 1


Well, this is embarrassing. Answering here so that someone else may find an answer, but I'm not proud of this one. :)

The solution was a simple one: Due to changing the port, neglected to also append the port to the login box in the vSphere Client.

So, updating from [machinename] to [machinename]:8443 worked just fine.

Thanks to RobM for starting me down the path of realizing I'd overlooked something basic.

  • 2
    Don't be embarrassed, these sorts of errors can catch anyone!
    – Rqomey
    Nov 27, 2012 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.