I have a physical disk from a HPUX system that I need to access from a Debian Linux for ia64 system. From the hpux-lvm-tools project I have the tools to access the HPUX LVMs (Linux LVM has a different format) and I also have the freevxfs driver.

I know beforehand that the disk has three partitions, and that the biggest one contains LVM volumes, and some of those are VxFS filesystems.

I can see the partitions:

# cat /proc/partitions

major minor  #blocks  name

   8       32  143374744 sdc
   8       33     512000 sdc1
   8       34  142452736 sdc2
   8       35     409600 sdc3

It finds a VG in one of the disk partitions:

# ./vgscan_hpux
On /dev/sdc2 - vg1328874723

# ./pvdisplay_hpux /dev/sdc2

PV General Information
VG Creation Time        Fri Feb 10 12:52:03 2012
Physical Volume ID      1766760336 1328874723
Volume Group ID         1766760336 1328874723
Physical Volumes in VG  1766760336 1328874723
VG Actication Mode      0 - LOCAL
PE Size                 64 MBs

Lvol sizes
lvol1 - 8 Extents - 512 MBs
lvol2 - 192 Extents - 12288 MBs
lvol3 - 16 Extents - 1024 MBs
lvol21 - 13 Extents - 832 MBs
lvol22 - 224 Extents - 14336 MBs
lvol23 - 16 Extents - 1024 MBs

Then I activate that VG and some new devices appear in my system:

# ./pvactivate_hpux /dev/sdc2
VG vg1328874723 Activated succesfully with 23 lvols.
# ll /dev/mapper/
total 0
crw------- 1 root root 10, 59 Nov 26 16:08 control
lrwxrwxrwx 1 root root      7 Nov 26 16:38 vg1328874723-lvol1 -> ../dm-0
lrwxrwxrwx 1 root root      7 Nov 26 16:38 vg1328874723-lvol10 -> ../dm-9
lrwxrwxrwx 1 root root      7 Nov 26 16:38 vg1328874723-lvol8 -> ../dm-7
lrwxrwxrwx 1 root root      7 Nov 26 16:38 vg1328874723-lvol9 -> ../dm-8


# mount /dev/mapper/vg1328874723-lvol18 /mnt/tmp
mount: you must specify the filesystem type
# mount -t vxfs /dev/mapper/vg1328874723-lvol18 /mnt/tmp
mount: wrong fs type, bad option, bad superblock on /dev/mapper/vg1328874723-lvol18,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

# lsmod |grep vxfs
freevxfs               23905  0

I also tried to identify the raw data with the file command and it just says 'data':

# file -s /dev/mapper/vg1328874723-lvol18
/dev/mapper/vg1328874723-lvol18: symbolic link to `../dm-17'
# file -s /dev/dm-17
/dev/dm-17: data

Any clues?

  • It would be nice if you added vgdisplay for the vg1328874723. Also, take a look at /proc/filesystems. There is no vxfs in Linux, but it might be called 'freevxfs' instead.
    – mdpc
    Nov 26 '12 at 18:44
  • I don't have a vgdisplay_hpux utility, only pvactivate_hpux pvdisplay_hpux and vgscan_hpux. The standard vgdisplay doesn't recognize my VG. /proc/filesystems shows vxfs (without 'nodev')
    – golimar
    Nov 27 '12 at 10:29
  • Try running fdisk -l against the devmapper and see what kind of filesystem it reports.
    – pauska
    Dec 10 '12 at 16:10
  • It says "Disk /dev/dm-17 doesn't contain a valid partition table". I tried several LVs
    – golimar
    Dec 13 '12 at 11:09

In the project page doesn't tell anything about which layout of VxFS are supported.

So I suggest you first check on your HPUX the VxFS layout

fstyp -v /dev/vg00/lvol3 | grep -i version

Then check if your VxFS layout version is supported by hpux-lvm-tools.

PS1: Partition 1: EFI, Partition 2 PV of OS, Partition 3 may contain support utilities. PS2: I can't see the link to post this as a comment instead of answer.

  • Thanks, I'll try that. I think you need more reputation to add comments
    – golimar
    May 20 '13 at 9:05
  • That command says "version 5", however I can't find which versions are supported in the FreeVxFS documentation
    – golimar
    May 20 '13 at 9:47
  • Ask to the developers of FreeVxFS. BTW if you are working in a production environment, I do not recommend do you use FreeVxFS. It could be dangerous. Is it absolutely necessary you present HPUX disk to Linux server?
    – RuBiCK
    Jun 9 '13 at 17:02
  • No, we just want to extract some files from a server that is not working anymore
    – golimar
    Jun 10 '13 at 7:41
  • 1
    Those are the normal Linux LVM commands, but for HPUX-type LVM there is only pvactivate_hpux, pvdisplay_hpux and vgscan_hpux. I checked the source code of freevxfs and I think it doesn't support VXFS 5...
    – golimar
    Jun 24 '13 at 7:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.