I have a dev server machine running Ubuntu 12.04. For a long while it's been throwing intermittent errors where it would suddenly tell me "File system is read only" or drop into a GRUB error console on boot. I've done disk checks, bad blocks, etc. and no real problems with the main SATA drive were detected.

Finally the drive would not be detected at all-- but neither would other drives I plugged in (via SATA).

I plugged the supposedly "bad" drive into another server and it worked fine, no issues, for days-- so I assumed the motherboard had a bad SATA controller, and replaced the motherboard with an identical model.

I replaced the drive into the original machine with the new motherboard, rebooted-- and the same issues-- I/O errors, failure to read the drive at all, dropping into GRUB, etc.

I'm wondering if there could be some other issue with this machine, that's not related to the drive-- possibly power supply?

Thanks for ideas


I replaced the power supply with a brand new 500W supply. Same issues. Removed the suspect drive, and used a brand new one-- went to do a fresh install of Ubuntu, and the installer crashed with an error warning of a "read only file system".

What could this be? I've already swapped out the HD, power supply and mobo. What's left? Is the machine just cursed?

  • have you checked the logs yet? Nov 29, 2012 at 4:24
  • Have you tried to reset the BIOS? Could it the AHCI harddrive settings?
    – Danie
    Nov 29, 2012 at 6:11

1 Answer 1


Yes. If your drive doesn't consistently get good power, it can't really spin the platters at a consistent rate, resulting in intermittent inexplicable read errors.

  • I once had a server I was about to throw out the damn window that was constantly crashing and bluescreening or having network errors or all sorts of weird shit. As a last ditch effort, I upgraded it to a 1kw PSU. All the problems went away. The upgrade from 4Gb to 32Gb of DDR2 FBDIMMs was too much for the old PSU to handle. So yes, PSU's can affect a lot. Nov 26, 2012 at 22:56
  • @MarkHenderson-- good thought there, I did upgrade RAM not long ago, so that could be pulling more juice than it's used to. I'll try swapping power supplies and report back.
    – user101289
    Nov 26, 2012 at 23:17
  • Please see my revisions to the post. I am stumped!
    – user101289
    Nov 29, 2012 at 3:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.