I've been looking for post related to my problem, but I have not found. I´m hopeless, I follow the guide for install and config nginx with fastcgi-mono-server ( http://www.mono-project.com/FastCGI_Nginx ), I do all how say in the guide but I can´t do that the nginx can interpret asp page.

My config pages in /etc/nginx/sites-available/default:

    listen   80;
    server_name  prueba;
    access_log   /var/log/nginx/prueba.access.log;

    location / {
        root /var/www/prueba/;
        index index.html index.htm default.aspx Default.aspx;
        fastcgi_index Default.aspx;
        include /etc/nginx/fastcgi_params;

The config of /etc/nginx/fastcgi_params:

fastcgi_param   QUERY_STRING            $query_string;
fastcgi_param   REQUEST_METHOD          $request_method;
fastcgi_param   CONTENT_TYPE            $content_type;
fastcgi_param   CONTENT_LENGTH          $content_length;

fastcgi_param   SCRIPT_FILENAME         $request_filename;
fastcgi_param   SCRIPT_NAME             $fastcgi_script_name;
fastcgi_param   REQUEST_URI             $request_uri;
fastcgi_param   DOCUMENT_URI            $document_uri;
fastcgi_param   DOCUMENT_ROOT           $document_root;
fastcgi_param   SERVER_PROTOCOL         $server_protocol;

fastcgi_param   GATEWAY_INTERFACE       CGI/1.1;
fastcgi_param   SERVER_SOFTWARE         nginx/$nginx_version;

fastcgi_param   REMOTE_ADDR             $remote_addr;
fastcgi_param   REMOTE_PORT             $remote_port;
fastcgi_param   SERVER_ADDR             $server_addr;
fastcgi_param   SERVER_PORT             $server_port;
fastcgi_param   SERVER_NAME             $server_name;

fastcgi_param   HTTPS                   $https;

fastcgi_param  PATH_INFO          "";
fastcgi_param  SCRIPT_FILENAME    $document_root$fastcgi_script_name;

fastcgi_param   REDIRECT_STATUS         200;

I have crate a Default.aspx page in /var/www/prueba/

Now I run:

fastcgi-mono-server2 /applications=prueba:/:/var/www/prueba/ /socket=tcp:

After, I start nginx:

/etc/init.d/nginx start

And when I try to access to "http://localhost/" or "http://localhost:80/" show me:

No Application Found

Unable to find a matching application for rquest:

    Host localhost
    Port 80
    Request Path /Default.aspx
    Physical Path /var/www/prueba/Default.aspx

I hope you can help me.


5 Answers 5


When starting fastcgi-mono-server I think it should be something like this:

fastcgi-mono-server2 /applications=/prueba:/var/www/prueba/ /socket=tcp:

I personally use this line to get mine running:

MONO_IOMAP=all  fastcgi-mono-server4 /socket=tcp:9000 /address= /applications=/:.,/dlr:/var/www/dotnet/dlr /logfile=/var/log/lighttpd/fastcgi.log &

As you can see mine uses fastcgi-mono-server4. It will probably work the same way.


To diagnose this kind of errors, try to add additional parameters to running fastcgi-mono-server:

/printlog=True /loglevel=All /verbose=True

Thus, you will see in console for which application request was sent.

Example of output for incorrectly configured server:

[2014-09-30 02:47:45Z] Notice  Beginning to receive records on connection.
No application defined for:
[2014-09-30 02:47:45Z] Notice  Finished receiving records on connection.

You should remove or comment out fastcgi_index Default.aspx; in your config.

  • Thx for answer VBart. I have removed fastcgi_index Default.aspx; in my config and nothing, when I try to access, throws a error: No Application Found Unable to find a matching application for request: Host localhost Port 80 Request Path / Physical Path /var/www/prueba/ I tried too sustituate fastcgi_index Default.aspx; by fastcgi_index /Home; because I saw in a post that whit this, the server could be able to interpret asp page but not work. Nov 27, 2012 at 8:42

You have to do the following:

  • make sure that you specified the same "server_name" and listen port in your conf file and in fastcgi mono server.

e.g. you are specifying in conf. file the name "prueba" with port 80 (default) so it should be the same as below.

in case framework 2:

fastcgi-mono-server2 /applications=prueba:/:/var/www/prueba/ /socket=tcp:

in case of framework 4:

fastcgi-mono-server4 /applications=prueba:/:/var/www/prueba/ /socket=tcp:


proxy_set_header Host $host;

to your nginx.conf

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .