I have run into a strange DHCP problem. The thing is the service is running, but the DHCP is not authorized. However, when I try to do it by right clicking, the option to authorize is not there - I can only choose to unathorize it. (Sorry, can't includa a SS).

When I click unauthorize, I get the error "The parameter is incorrect." So now I'm stuck with unauthorized DHCP server that for some reason only can be authorized. I have tried all the usual stuff except re-installing the service. Anyone here have a clue what it can be?

1 Answer 1


Have you tried to unauthorize DHCP-server this way? >>

  • Open DHCP snap-in.
  • In the console tree, click DHCP.
  • On the Action menu, click Manage authorized servers.
  • The Manage Authorized Servers dialog box appears.
  • In Authorized DHCP servers, select the server you want to unauthorize.
  • Click Unauthorize.
  • Tried it and while I can click both unauthorize and authorize without error, the result is sitll the same - the DHCP server stays unauthorized. checking Event Viewer, I get the following error: "The DHCP service failed to see a directory server for authorization."
    – Sandokan
    Nov 27, 2012 at 12:29
  • Looks like DHCP-server doesn't see your DC. Firewall/connection/DNS issue? Does DHCP reside on the same machine there the AD DS is installed? Is DC available at all? Nov 27, 2012 at 12:41
  • Yes, this is the first server and it's all on the same machine.
    – Sandokan
    Nov 27, 2012 at 12:45
  • Restart DHCP server from DHCP mmc. Then check if the server can be authorized. My guess is that DHCP server starts before Active Directory starts. Is this W2k8 machine? Nov 27, 2012 at 12:49
  • Still no luck. It's a 2003, as my tag should show.
    – Sandokan
    Nov 27, 2012 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.