Trying to setup a MDT 2012 enviromnent. Plan is to roll out Windows 7 with MDT.

Server: Windows 2008 R2 Standard
Windows Automated Installation Kit for Windows 7
MDT 2012, Update 1
WDS configured for PXE boot

Added a deployment share, added operating system files (Windows 7 64 bit pro), drivers for network interface for test machine, created the boot media, and placed this on the WDS.

Starting PXE just fine with the boot-wim-file. Reaching WinPE, starting the Wizard automatically, gathering information, and is finally prompted with the "Microsoft Deployment Toolkit".
With the option to "Run the Deployment Wizard to install a new Operating System" or "Exit to Command Prompt".

When clicking on "Run the Deployment...." I'm faced with an error: "A connection to the deployment share (\\mdtserver\deploymentshare$) could not be made. Connection OK. Possible cause: Invalid credentials"

Pressing F8, to reach a command prompt. "ipconfig" shows an IP-address. I can PING the deployment server. I can mount the Deployment share using "net use" and providing the username/password added in the bootstrap.ini.

Bootstrap.ini contains:

I've been trying all I can think of, but Im still faced with this error.

According to all instruction videos and all manuals I have read/seen, I do the same thing as everybody else, it's just that my config doesn't work :(

  • In my experience you need to have the FQDN for the server e.g., \\server.contoso.com\deploy$ did you try that?
    – Hugh
    Mar 18, 2013 at 17:22

3 Answers 3


Found the reason.

I was using Swedish version of the 2008 R2 OS.
Installed again with English 2008R2, and after that I had no problem at all.

So Swedish OS was the problem here. Installed English version of AIK also.

So case closed


Is this a typing error:


In the error message you posted, you wrote it as \mdtserver\deploymentshare$, but in your bootstrap.ini it is \mdtserver\deploymentshare$. That one slash can make a big difference.

Please remember that any changes to the bootstrap.ini require your deployment share to be updated and the media needs to be regenerated, including replacing the LiteTouch boot media being used by WDS for the PXE boot.

Also, according to the MDT help files, you should have the UserID, UserDomain, and UserPassword settings in both the bootstrap.ini and the customsettings.ini (deployment share rules). Also, no quotes around them.

Lastly, I'd like to give you a tip about log files. In the MDT help files, look up SLSHARE. This setting will save all the log files into your deployment share (if that's the location you set), so if there is an issue the logs are easy to find.

  • Hi.Thanks for responding. Yes, its a typo. Its written with 2 backslashes in the config files (\) One was trunkated when writing this post :) Don't use quotes in the bootstrap either. I always update the WDS with new boot image after changing settings in them. Still struggling with this, and don't have any good way forward right now. Still trying in my lab environment to get this working. Im thinking this might be related to our AD environment, but im not sure how....
    – Micke
    Nov 29, 2012 at 7:55
  • @Micke I found this TechNet forum thread that says that this is a problem with using WAIK (WinPE3.0) with MDT 2012. Try removing WAIK and installing WADK instead.
    – dwolters
    Nov 29, 2012 at 19:56

I'm not so sure that the OS version would be the cause here. I ran into a similar issue when I was playing with variables in the bootstrap.ini. I made changes to UserDomain, UserID, etc. and ran my build and capture again, but none of the changes took hold (despite updating the deployment share, etc.). Then, it dawned on me that it was operating like it always had, and perhaps it had the previous vbs and wsf files cached. So, I ran a diskpart and cleaned the disk. Lo and behold! I kicked it off again and the changes to my bootstrap.ini took hold!

Perhaps, making a change to the OS probably didn't do much. Making a change to the AIK, though...that probably flipped everything.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.