I just finished separately installing vCenter Server 5.1. I installed the components separately but on the same machine using a local SQL 2008 R2 DB (not SQL express).

Everything appears to be working correctly with the exception of SSO. It doesn't find the AD server. This is to be expected (see below) but I don't know how to fix it.

Potential Leads / Steps taken

  • During the install of SSO, I was logged on as a local administrator (waiting on central IT dept to create a service account). As a result, I received a message saying that SSO wouldn't be able to automatically locate the AD. (fair eonugh)
  • After I read up on it a little bit, I believed I could go into the SSO Configuration option in the Web client, like so:

What I expect to see on the Sign-On and Discovery Menu

However, what I actually see is:

What I actually see on the Sign-On and Discovery Menu

  • I also notice that the "SSO Users and Groups" entry is not there. Betting that has something to do with it as well.


  • How can I get the "Configure" Option to show up for SSO?
  • Overall goal: How can I manually enter the AD server in this scenario while logged in as a local administrator?


  • If you log into your VCenter via IPofVcenter:5480 and configre AD and SSO from there you should be able to do the edits form the Web Client. – Zapto Nov 28 '12 at 16:54
  • @t1nt1n when attempting to browse to that site, it appears that nothing is there. have tried http/https and IP/FQDN in the browser to access that port. Have also tried accessing this url both remotely and locally. Can you provide some more insight into why you're suggesting these steps? – SeanKilleen Nov 28 '12 at 19:11
  • Sorry ingore me! Anwsering 2 questions at the same time. If you had the linux version of Vcenter that is how yo would confire SSO. WHat browser are you using? Web Client is a bit iffy in Chrome. – Zapto Nov 28 '12 at 21:29
  • Thanks for that tip! I'm using chrome; didn't think it could be the browser. I'll check tomorrow and see if that's it. – SeanKilleen Nov 29 '12 at 2:06

For 5.1: Log in using the user account: admin@System-Domain You set up the password during installation.

This is a bit unclear for users, but is in the documentation.

You may be locked out after three incorrect attempts, but this will reset after about 15 minutes.

You will then be able to configure everything, particularly adding your Local/Domain Administrator user to the sso admin role.

NB. The documentation is a bit dense, but there is a nice blog post here, which has helped me. The final link I will give is a table of Roles vs. install versions which may be helpful. People are using the simple install which is causing problems later on.

For 5.5: You can log in using Administrator@vsphere.local

  • 1
    This was exactly it and fixed the problem. Thanks for the concise answer! To round it out, do you have a link to that doc or the name of it? I think others might benefit from having the point of reference. – SeanKilleen Nov 29 '12 at 13:18
  • 1
    @goober I added some links there, I hope they are helpful. I believe there is an update coming out in Q1 2013 which may help make things a bit simpler during the install. – Rqomey Nov 29 '12 at 15:49
  • 1
    In vSphere 5.5 I believe the user is administrator. – user192343 Oct 2 '13 at 11:31
  • Added 5.5 login – Rqomey Oct 3 '13 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.