We just acquired 7 new Dell Optiplex machines with Vista 64 bit installed. We installed all of our tools and applications on one of the machines and then used Norton Ghost to deploy to the other 6 machines. We have found that the ghosted machines do not recognize any USB keyboards at all when booted into Windows.

The USB mice work fine. We tried all of the 6 different USB ports with both keyboards and mice; the mice work on all 6 ports but the keyboards do not work on any of them.

All these keyboards work fine on other computers. They work in the BIOS and when booting off the system restore disc to run the recovery tools / repair / restore / reinstall options, just not at the main Windows login prompt or beyond. The same behavior occurs in safe mode as well.


We initially thought that this was limited to a keyboard/USB issue, but it seems to be deeper rooted than that. If we use the on screen keyboard to get past the login prompt we are just stuck at a blank screen. Just the default blueish background wallpaper with no shell, no ability to used the on screen keyboard to bring up task manager or anything like that.

Any ideas what the problem might be or how to proceed?

  • What shows up in device manager? If you delete the keyboard in device manager, and connect the usb keyboard does it reappear? – JS. Jul 24 '09 at 21:30
  • What other tools and applications did you load? Was VMWare one of them? – Adam Brand Jul 24 '09 at 21:41
  • Did KB938194 get installed (Control Panel/Windows Update/View Update History)? – Adam Brand Jul 24 '09 at 21:45
  • The VMWare Player was installed, along with development tools (Visual Studio, Oracle client, IIS, Firefox, Chrome, etc). – wweicker Jul 24 '09 at 21:47
  • How about KB938194? – Adam Brand Jul 24 '09 at 21:57

I suspect this has something todo with a bug in VMWare's USB driver OR KB938194.

Try uninstalling VMWare and see if that fixes it. Otherwise look at:


See if UpperFilters is set to something like "kbdclass vmkbd". If so, put vmkbd first in that list.

If that doesn't work, try uninstalling the Windows Update KB938194.

In googling around, it seems like there have been reported issues with VMWare and with that KB when it comes to USB keyboards.

That doesn't address the issue that (I assume) the initial machine worked fine while its ghost clones didn't, but at least it provides some things to try.

Reference to VMWare Issue | Reference to KB Issue


Now that I see your edits (not working at all after logging in), I think it is probably a bigger issue. I would try redoing the ghost image and re imaging. I'll keep the above in place in case anyone had a similar issue that those steps could solve.


Well we gave up on Norton Ghost. Instead we made a full system backup onto a USB drive, then booted into the system restore console on each new machine, clicked repair, and restore from a backup. This appears to work, all we have to do is change the machine name and activation key after each machine is restored from backup.


I have had this happen with images that were created on machines with PS2 keyboards. Its been awhile, but I believe I either waited a few min for the usb KB to be installed or I logged in with a PS2 keyboard and then plugged in the usb keyboard and let it install.

Your issue sounds a bit more complicated though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.