I have an HP ProLiant DL370 G6 server that I am using as a workstation. It takes 60 seconds during reboot and cold boot before screens post with a discrete Radeon HD6xxx GPU. What can I do to make it boot faster?

I have had a chance to use HP Gen8 server. It posts quickly and shows various CPU/memory/QPI initialization steps. Still takes a long time, but at least I can see what's going on.

  • FWIW, that's a crapload faster than the Dell M610, M700, and M710 blades that I was working with at my last job. – mfinni Dec 4 '12 at 3:15
  • @mfinni In other news: Dell's reliable memory technology is actually good for you. My question is about the specifics of HP server. I am curious to find out what takes that long, actually, and how to turn this thing off :) – GregC Dec 4 '12 at 14:29
  • That's why I posted a comment: I don't have an answer to your question :-) – mfinni Dec 4 '12 at 15:45
  • 2
    The Gen8 servers were modified to show early initialization steps on the console shortly after power-on. The boot and POST times are similar to the G7, but I suppose it gives people a warm-fuzzy to see something on the screen. – ewwhite Nov 1 '13 at 21:52
  • Yuppers. Warm fuzzies all around :) – GregC Nov 1 '13 at 21:59

There's no option here. Since the advent of the Nehalem and newer CPU's, the POST time on HP systems has grown tremendously.

I see that you're using this as a workstation. Is there any option to leave the system running and take advantage of some of the BIOS power management options?

  • 3
    For truth. They all take an extremely long time to POST. In an outage where minutes matter, it's rather annoying. – sysadmin1138 Dec 3 '12 at 21:05
  • It helps to disable option roms for network booting. – hookenz Dec 3 '12 at 21:05
  • @Matt I am talking specifically about the time before screens post. Option ROMs for a myriad cards is a battle for another day. – GregC Dec 3 '12 at 21:06
  • 1
    @sysadmin1138 I'm about to send a G5 ML370 to another SF user. It boots in 60 seconds. The G6 variant of the same server is 90-110 seconds. – ewwhite Dec 3 '12 at 21:06

Nothing. HP's proliant servers simply are very slow at booting. G7 is even worse and G8 (just testing them now) hasn't improved things either. It looks shinier, but is slower still to boot.

  • 1
    Who needs fast boots? I just let the servers run until they die... # uptime 15:09:27 up 1033 days, 10:16, 39 users – ewwhite May 30 '13 at 22:09
  • 2
    To make clear for others years later, high uptime, such as this, misses an important piece for production environments. Missing kernel updates is not a good thing. – Bill Carlson Apr 10 '17 at 18:57
  • @BillCarlson Kernel (at least, in Linux) can be patched without a reboot, but I agree with you - missing kernel updates is not a good thing – Denys Vitali Jul 26 '17 at 15:15

Use kexec to reboot your server. This skips the pre-boot procedures entirely, and reboots into a Linux kernel at the end of the Linux shutdown process, rather than resetting the hardware and going to POST.

Unfortunately kexec is a bit cumbersome to use, so I wrote a script to make it easier to work with: kexec-reboot will allow you to choose a kernel from your grub boot list, or simply kexec the latest available kernel.

  • It's aiiiight. – ewwhite Mar 25 '15 at 11:44

My preferred solution to the horribly slow G8 bios boot time is to install the the free VMware vSphere Hypervisor instead of running the OS directly on the server.


  • 6
    Wut?!? That doesn't even make sense! – ewwhite Feb 13 '15 at 21:30
  • 1
    At some point, you'll have to patch and reboot the host running on the bare metal. Or you'll have a fault that causes same. Running ESXi instead of Windows or Linux won't change the boot time of the hardware. – mfinni Feb 13 '15 at 21:38
  • 5
    Say you reboot 100 times/year.. 90 are related to Windows Update, and 10 are related to Hardware maintenance.. Then you have a 90% faster boot time using a hypervisor. – moander Feb 14 '15 at 23:14
  • 2
    Having just spent a week debugging a Red Hat kickstart script that wasn't working as intended, this would have drastically reduced my work time. It wasn't the hardware that was faulty or needed patching, it was the Linux OS on top of that hardware. VMWare would make things so much easier. – shearn89 Feb 1 '16 at 16:47

I had a problem where the first white "HP Proliant" screen wasn't showing up for about 5 minutes. Clearing the NVRAM solved the problem.

Clearing the NVRAM will clear out all "BIOS" settings, so if you don't want that to happen, then you don't want to clear your NVRAM.

Try clearing the NVRAM:

  1. power off the machine, unplug all PSUs
  2. open the case and find the DIP switch with 10 switches, and flip switch 6 (right) with a paper clip.
  3. plug in the machine and power it back on for 3-5 minutes. power off the machine, unplug all PSUs
  4. open the case and find the DIP switch with 10 switches, and flip switch 6 to off (left).
  5. turn the machine back on.

I did not simply try removing power to allow all components to discharge for any period of time, so it's possible that removing power alone resolved the problem.


  • Did you capture your CMOS settings and then set them to the same ones? – GregC Dec 12 '16 at 14:34
  • This is akin to formatting your SSD and reinstalling from fresh media when some feature in Linux doesn't quite work. – GregC Dec 12 '16 at 14:35
  • True. It was no problem for me as I was repurposing the machine when I came across the issue. I'll put a warning in the answer. – mbrownnyc Dec 12 '16 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.