4

I have SSRS 2008 R2 installed on my server and need to deploy report from Business Intelligence Studio at another computer which is in the same domain and under domain user (non-administrator).

First I get the error "Unsufficient permissions". Then I started Report Manager at the server (http://localhost/Reports/) and under Site Settings / Security added my domain user to both System Administrator and System Users roles, restarted the service, but still got the same error.

Then I created a folder in Report Manager and added domain user to all available roles for that (Browser, Publisher, etc.). After that it doesn't show that error in BIS but instead shows the login dialog (though I already logged as domain user in Windows). I enter login and password but it just asking it again and doing nothing. Tried to enter administrator login details but it also just shown again.

Could you advice me how to enable access to the service or at least to some folder for non-administrator domain user?

  • What browser is being used when the prompt for credentials occurs? I'd recommend using IE as a test to rule out any authentication problem from other browsers. – Mike May 21 '16 at 14:52
  • It is important to add the user in the form <domain>\<user> when assigning permissions. – hot2use Apr 4 '17 at 17:56
0

Try changing the following setting in the RSeportServer.config file: AuthenticationType to RSWindowsNTLM

see more info here: http://msdn.microsoft.com/en-us/library/cc281253.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.