Background / Setup

I've got a fresh install of vCenter Server 5.1 and associated components.

I've taken all steps (as far as I can tell) to enable FT, and it worked the first time (yanked a power cord and watched a VM keep working -- an awesome feeling, by the way).

The steps I took were:

  • Create an HA cluster with two servers
  • Add an additional Virtual VMkernel NIC to handle FT traffic on each host
  • Ensured that all hosts have access to multiple network storage devices (EMC and netapp).
  • On a VM, changed the CPU/MMU Virtualization option to "Use Intel VT-x/AMD-V For Instruction set virtualization and software for MMU virtualization"
  • Right-clicked on the VM and selected "turn On fault tolerance". This completed successfully.

Again, this worked.


Now, however, in the VM menu, after all hosts have come back on-line the option is again to "turn On Fault tolerance" (I thought once on, it would stay on?)

Additionally, if I click to turn fault tolerance on again, I receive the message "The virtual machine is running in a monitor mode that is incompatible for fault tolerance." However, selecting VT-x/AMD-V is what fixed this problem last time before my initial test that worked, and it is still selected in the menu.


  • Is this a bug in the display, and the machine is still fault tolerant?
  • Is this something I need to reconfigure each time?
  • Once a machine has been configured for fault tolerance, does it remain in that mode perpetually? My guess would be that it should, but this experience makes me question it.

Update: More information (potential lead?)

To make matters more interesting, I just tried the following:

  • Set CPU/MMU on the VM back to "Automatic"
  • Rebooted the VM
  • Set the CPU/MMU back to the intel setting that worked the first time
  • Rebooted the VM
  • Clicked "Turn Fault Tolerance on"
  • ...and received the same error.


  • 1
    I'm not running 5.1 but did you try the "test fault tolerance" option on the VM to see if it succeeds or not? This is non-invasive, just to ensure it actually will or will not work, without pulling power like you did and hoping.
    – TheCleaner
    Dec 4, 2012 at 14:42
  • Normally I would, except that now the only option in the fault tolerance menu is "turn fault tolerance on". It was already previously turned on, and I executed the test without using this option (which I will consider next time). It appears VMWare thinks it is no longer fault tolerant. And I can't change the CPU/MMU options without restarting. Which means 2 restarts for a VM whenever a fault occurs to reconfigure FT. Seems like a bug / issue. Dec 4, 2012 at 16:56
  • @TheCleaner also, please see updated question. I reset the VM to the same settings that worked the first time but it still won't turn FT on. My guess is it's already on still (from the first time) but vCenter is confused somehow. No idea how to verify that, though. Dec 4, 2012 at 17:27
  • 2
    Do your hosts not support automatic on the cpu/mmu? Did you actually power cycle the VM or just reboot the underlying OS? Are the hosts identical or no?
    – TheCleaner
    Dec 4, 2012 at 17:33
  • 1
    Welcome. I'll check with the mods on cleaning up the comments here. You can post the answer as an actual answer and accept your own later. But feel free to upvote my comment on the power cycle ;)
    – TheCleaner
    Dec 4, 2012 at 19:04

1 Answer 1


The answer in this case, both unfortunately and fortunately, appeared to be simple.

The error seems to be related to the fact that the VM was still powered on.

After powering off the VM, the fault tolerance option was able to be put in place.

In this case, VMWare appears to generate an error message that isn't very helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.