We have two servers, one running Windows Server 2003 SP2 and one running Windows Server 2008 R2. Both servers have their own versions of Group Policy Management (1.0.2 on 2003 and on 2008).

We are wanting to migrate everything over to the newer 2008 server, including software deployment. However, when I try to add a new software package using a .msi file, I get the following error:

"The schema for the software installation data in the Active Directory does not match the required schema."

I have tried two separate software packages and get the same error on the 2008 server. However, when I do the same on the 2003 server, it adds the software package without any problems.

The .msi files I am using are up-to-date - one is the most recent version of Google Chrome.

Is this problem caused by the different versions of the OS, or the Group Policy Management program? How do we "upgrade" our Active Directory to allow software deployment on the 2008 server?


  • 2
    What's your domain and forest functional level? I recall this being a common problem when trying to raise the FL to 2003 from 2000, and I wonder if perhaps you're still running a 2000 FL that's causing issues with your 2008 server. – HopelessN00b Dec 5 '12 at 11:49
  • Domain and forest functional level both Windows Server 2003. – weedave Dec 5 '12 at 12:31
  • 1
    Did you run forestprep and domainprep before adding the 2008 R2 DC? – Paul Ackerman Dec 5 '12 at 12:39
  • I'm not sure, the upgrade was carried out by an external company. I'll try and find out from them. In the meantime, is there any way of telling? – weedave Dec 5 '12 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.