1

I have an old WinXP Pro SP3 computer I need to join to the domain, simple right? not really. When I go to control panel -> system -> computer name and click on CHANGE ("rename this computer") everything is greyed out. I can not set it from workgroup to a domain.

enter image description here

I am logged on locally as an admin. (Builtin account and one I created) I have checked local policy (gpedit.msc) on the comp, but it feels like a needle in the haystack. I could probably reload an image faster than trying to fix this...but I am curious so I post here to see if anyone knows of it/fix.

I tried reseting the policy to defaults, but no luck:

secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose

EDIT1: enter image description here

EDIT2: Computer Browser & Workstation Services are not running

  • The Workstation service terminated with service-specific error 2250 (0x8CA).

  • The Computer Browser service depends on the Workstation service which failed to start because of the following error:

  • The service has returned a service-specific error code.

  • Could not load RDR device driver.

EDIT3: "mrxsmb.sys" in system32/drivers is a trojan, which is needed for WorkStation

5
  • 2
    Are you positive that this is a pro machine and not home edition?
    – MDMarra
    Dec 7, 2012 at 22:13
  • When you go to control panel -> system -> general it does state WinXP Pro Sp3. I checked this like 3-4 times to make sure :) Because that was my first thought.
    – Logman
    Dec 7, 2012 at 22:53
  • 1
    Do you have the "Computer Browser" service present and started?
    – user72593
    Dec 7, 2012 at 22:57
  • actually no it is not, WORKSTATION is not either
    – Logman
    Dec 11, 2012 at 18:47
  • Please post your solution as an answer and mark it accepted when you are able.
    – jscott
    Dec 12, 2012 at 0:31

1 Answer 1

1

Client for Microsoft Networks needs to be installed and enabled on the network adapter that is on the Windows network.

enter image description here

Then determine if your workstation service is started. The workstation service is required to join a domain:

enter image description here

6
  • It did have Client for Microsoft Networks. I posted a screen grab from the network connections dialog above.
    – Logman
    Dec 7, 2012 at 21:43
  • Workstation service is not running.
    – Logman
    Dec 11, 2012 at 18:47
  • @Logman Workstation service needs to be running.
    – Wesley
    Dec 11, 2012 at 19:11
  • Yes, I tried turning the service on but it failed. Checked the event logs briefy, but I did not get much chance to dig deep into it yet. I have to do this remotely, and it is in a busy office (front desk).
    – Logman
    Dec 11, 2012 at 23:13
  • I was going to uninstall the network properties..."Client for MS Networks" and "File and Print Sharing" to start...but do it remotely with a person on hand that has no comp knowledge..eek
    – Logman
    Dec 11, 2012 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.