I am trying to make screen work on HP-UX B.11.23 U ia64 0308561483 unlimited-user license. Please notice I do not have root access.

I have already compiled screen successfully, configured with LIBS=-lcurses.

When I try to start screen it wrotes
Cannot find terminfo entry for 'xterm'.

But there ARE terminfos for the terminal type in

screen-4.0.3> ls -a /usr/share/lib/terminfo/x/
.         ..        x-hpterm  x1700     x1720     x1750     xitex     xl83      xterm     xterms

I thing the problem may be there are in non-standard path, because according to man page standard path is /usr/lib/terminfo/?/*

What I tried:

But as I said I do not have root access so cant make symlink, anyway I tried run screen with filled TERMINFO_DIRS (TERMINFO_DIRS=/usr/share/lib/terminfo/x/ ./screen and TERMINFO_DIRS=/usr/share/lib/terminfo/ ./screen) but none of them work - same error.

Change TERM to different values - same error Cannot find terminfo entry for <WHATEVER WHAT WAS IN TERM VAR>.

Put something into screenrc and run ./screen -c screenrc

screen-4.0.3> cat screenrc
attrcolor b ".I"
term xterm
termcap xterm*  LP:hs@
termcapinfo xterm 'Co#256:AB=\E[48;5;%dm:AF=\E[38;5;%dm'
defbce "on"

I also tried to compile it against termcap from http://hpux.connect.org.uk/hppd/hpux/Development/Libraries/termcap-1.3.1/, but it also did not work, same symptoms.

Is there anyone who has working screen on this platform and could post output of ldd or binary itself?

But no luck so far, have you got any suggestions? Need some additional information, let me know. Also please see strace attached in comments.

  • Do a strace on screen and see where it stats. If possible, create a symbolic link to inform of the correct location of your terminfo for screen. – deed02392 Dec 11 '12 at 10:56
  • Here is strace pastebin.com/W6rYdf2A, but it does not seems to be helpfull to me, the path nor file is not mentioned – Ency Dec 11 '12 at 11:30
up vote 1 down vote accepted

The installation instructions for screen on HPUX say


* Install termcap first and *then* screen. If you do it the other
  way around, screen will not work because the termcap entries will be
  missing. If you update termcap in the future, you will need to
  re-install screen afterwards of course.

Did you actually install termcap or did you just compile against it?

  • I finally make it work! I figured out, there already was some termcap in system but on very special place, so I had to add this path to LDOPTS variable and it start working, with kind of limited functionality (no colors, if I attempt to modify hardstatus colors screen aborts itselfs, but it is termcap limited capability, according to gdb) – Ency Dec 12 '12 at 14:42

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.