I tried to start Routing and Remote Access Service but I've got an error says the dependency service or group failed to start then I tried to start Remote Access Connection Manager (one of RRAS's dependencies) and the error way same. then I tried to start The Secure Socket Tuning Protocol Service but there was an error says that the the service started then stopped!

the errors form event log is here:

The Remote Access Connection Manager service depends on the Secure Socket Tunneling Protocol Service service which failed to start because of the following error: The operation completed successfully.

The Secure Socket Tunneling Protocol Service service entered the stopped state.

The Routing and Remote Access service depends on the Remote Access Connection Manager service which failed to start because of the following error: The dependency service or group failed to start.

sort by date

Does anyone know how can I resolve the problem?

  • Have you considered adding SOME Information? Like - is there anything in the event log? Normally starting services leave separate event log explanations. – TomTom Dec 14 '12 at 10:20
  • @TomTom ok I'll add them – ahmadali shafiee Dec 14 '12 at 10:21
  • @TomTom I'm nob in windows server. can you tell me where I can find the exents of the services? I opened Event Viewer but I don't know where to go! – ahmadali shafiee Dec 14 '12 at 10:29
  • @TomTom I've added the data from Event Log – ahmadali shafiee Dec 14 '12 at 10:38

A couple of things to try without seeing your full event log:

  1. Try backing up your registry and then deleting the following key: HKEY_LOCAL_MACHINE\System\currentcontrolset\services\remoteaccess\routermanagers\IPV6 and then rebooting.
  2. Try removing the RRAS role completely from the server in Server Manager Roles and rebooting then re-adding the RRAS role. (NOTE: if you have extensive rules/policies/settings within RRAS you will need to document them and recreate them. See here: http://winmasterplan.blogspot.com/2008/01/export-rras-configuration.html
| improve this answer | |

It's strange but if you disabled Remote Registry, you have to change it strtup type to manual. service Remote Registry= disable -> manual

| improve this answer | |
  • it's startup is manual and the problem doesn't resolved – ahmadali shafiee Dec 20 '12 at 16:14

I solved the problem for myself (on Server 2008 R2) when I did the following:

  1. Control Panel > Device Manager > View > Show Hidden Devices. Under Network Adapters, make sure all are enabled (I don't know which ones are the necessary ones).

  2. Control Panel > Network and Sharing Center > Change Adapter Settings. Right-click each adapter, choose Properties, then IPv4 Properties, then Advanced, then WINS tab, then Enable NetBIOS over TCP/IP. Don't know if this was part of the solution, but it was a change I made before RRAS started working.

You may have to then reboot the server.

| improve this answer | |

The problem was from my VPS provider. They disabled VPN option. We asked them and they Enabled it for us. Now this is our problem!

| improve this answer | |

I was having the same problem. I had disabled a host of network devices that were needlessly sucking up all the IPs in my DHCP pool. When I went and deleted those connections which we will never use, they stayed in the list, however, when I went bgack and enabled each one they disappeared, and once they were all gone, SSTP service started backup as advertised.

| improve this answer | |

Open services.msc and double click Routing and Remote Access, go to Dependencies tab and note which services are required for this service to be started.

Once this is done try starting up each of the dependencies that are not already started, if for some reason they are unable to start you'll be given a communicate and there should be an event in the Event Log corresponding to that problem.

Depending on which service is unable to start there are different methods of further diagnostics.

| improve this answer | |
  • I told that The Secure Socket Tuning Protocol Service doesn't start! – ahmadali shafiee Dec 19 '12 at 7:02
  • 1
    Are there any events in the System or Application logs about that service? They can have Source set to Service Control Manager or a specific name for that service. Basically try to start it again and then refresh the Event Log and look for any events that match the exact time of you starting that service. – mprill Dec 19 '12 at 15:39
  • I checked the system events and the log about this was The Secure Socket Tunneling Protocol Service service entered the stopped state. – ahmadali shafiee Dec 21 '12 at 9:22

The windows event log will be disabled. That causes SSTP to stop, hence start windows event log in control panel/services. That should help.

| improve this answer | |

For me, rebooting my VPS fixed the problem. It manifested itself firstly as the IIS web server not being able to talk to the sql server. I could connect to the SQL Server then I found this SSTP problem.

It may be to do with a proxy server and a mail server I also have running on this box - like too many connections or something.

| improve this answer | |

I had the same problem and I did the followings and the problem solved:

In Services:

-"Windows Event Collector"->Properties->Startup Type->Automatic(Delayed Start).

-"Windows Log"->Properties->Startup Type->Manual.

-"Remote Access Auto Connection Manager"->Properties->Startup Type->Manual.

-"Remote Access Connection Manager"->Properties->Startup Type->Manual.

-"Remote Desktop Configuration"->Properties->Startup Type->Manual.

-"Remote Desktop Services"->Properties->Startup Type->Manual.

-Remote Desktop Services UserMode Port Redirector"->Properties->Startup Type->Manual.

-"Remote Procedure Call (RPC) Locator"->Properties->Startup Type->Manual.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.