1

I face an annoying and hard to track its root problem with squid3 proxy server running on Ubuntu Server 12.04.

Squid is working fine for all websites I have tried so far to access, except http://ubuntuforums.org/

What I get is the following error:

ERROR

The requested URL could not be retrieved

The following error was encountered while trying to retrieve the URL: http:// ubuntuforums.org/

Access Denied.

Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.

Your cache administrator is webmaster.

Notice also that the cache administrator is webmaster, while I have changed the cache_mgr parameter in the squid.conf file with my own e-mail and for any other errors I see it properly.

In the access.log I see this every time I try to access this web page.

1355572568.095 217 192.168.0.10 TCP_MISS/403 4567 GET http:// ubuntuforums.org/ - DIRECT/91.189.94.12 text/html

The bizarre thing here is that I can access sub paths of the same domain like http://ubuntuforums.org/index.php without any problems!

I tried to purge the cache for this website using squidclient but again I get the following error:

# squidclient -m PURGE http://ubuntuforums.org/
HTTP/1.0 404 Not Found
Server: squid/3.1.19
Mime-Version: 1.0
Date: Sat, 15 Dec 2012 12:14:48 GMT
Content-Length: 0
X-Cache: MISS from localhost
X-Cache-Lookup: NONE from localhost:3128
Via: 1.0 localhost (squid/3.1.19)
Connection: close
1

If your data is correct, then there ist nothing wrong with squid.

The url you posted is http:// ubuntuforums.org/ - see the space between http:// and ubuntufoums.org/

  • It's been a long time since I had this problem. After a few days, the problem was "automagically" fixed. So indeed, it could be some mistyping, however, I am pretty sure I had tried to retype the link again and again. Thanks for point this out though! – Vangelis Tasoulas Jul 1 '15 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.